Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

команды БСП и расширения 8.3.13

команды БСП и расширения 8.3.13
Я
   Geroy
 
19.11.18 - 23:43
Типовая
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

Необходимо, но не работает
&Вместо("Подключаемый_ВыполнитьКоманду")
Процедура Расш_Подключаемый_ВыполнитьКоманду(Команда)

КонецПроцедуры
 
 
   Geroy
 
1 - 19.11.18 - 23:51
&НаКлиенте
Процедура Расш_Подключаемый_ВыполнитьКомандуВместо(Команда)

Тоже не работает
   Chameleon1980
 
2 - 20.11.18 - 06:57
У расширения отключи безопасный режим. или как он там называется.
   Geroy
 
3 - 20.11.18 - 07:49
(2) отключено всё, я не уверен что команды БСП в расширении перехватываются, это же не команды формы.
   Chameleon1980
 
4 - 20.11.18 - 08:21
а какая разница БСП это или нет?
   Chameleon1980
 
5 - 20.11.18 - 08:22
Это модуль жеж типа общий?
   Geroy
 
6 - 20.11.18 - 08:25
(5) нет это в форме документа или в форме списка.
   Geroy
 
7 - 20.11.18 - 08:26
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры
   Mankubus
 
8 - 20.11.18 - 09:09
(3) а обычные процедуры перехватываются чтоли? тоже думаю что не в БСП дело
   Geroy
 
9 - 20.11.18 - 09:18
(8) всё остальное работает отлично, скорее всего связано что данная команда не откуда не вызывается.

Это ведь не события формы
   Cyberhawk
 
10 - 20.11.18 - 09:21
Серверные методы, не являющиеся обработчиками события формы, в безопасном режиме не расширяются
 
 Рекламное место пустует
   Geroy
 
11 - 20.11.18 - 09:29
(10) повторюсь всё отключено
_http://rgho.st/74NpfFVkl скриншот
   Geroy
 
12 - 20.11.18 - 09:31
   Cyberhawk
 
13 - 20.11.18 - 09:51
Хз о чем ты
   Geroy
 
14 - 20.11.18 - 10:26
(13) Открой любой документ, и в нём есть 3 обязательных команды БСП.

// СтандартныеПодсистемы.ПодключаемыеКоманды

&НаКлиенте 
Процедура Подключаемый_ВыполнитьКоманду(Команда)
          ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры 

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
          ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры 

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
          ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры 
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды


Мне необходимо перехватить 

&НаКлиенте 
Процедура Подключаемый_ВыполнитьКоманду(Команда)
          ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры
   Cyberhawk
 
15 - 20.11.18 - 10:30
Хз зачем ты это пишешь мне
   Geroy
 
16 - 20.11.18 - 10:54
Решение.

Было:

&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

Стало:

&НаКлиенте
&Вместо("Подключаемый_ВыполнитьКоманду")
Процедура Расш_Подключаемый_ВыполнитьКоманду(Команда)    
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры
   asady
 
17 - 20.11.18 - 11:12
(16) здравствуй костыль!
   Cyberhawk
 
18 - 20.11.18 - 11:23
(17) Намекаешь на "ПродолжитьВызов" или как-то еще надо было? :)
   Geroy
 
19 - 20.11.18 - 11:25
(17) и где тут костыль? мне нужно перехватить выполнение определенной команды
   Cyberhawk
 
20 - 20.11.18 - 11:27
(19) Ну как минимум костыль в том, что ты скопировал текст исходного метода и все это развалится, когда его поменяют в основной конфе (не берем в расчет вероятность наступления - только сам подход)
   unregistered
 
21 - 20.11.18 - 11:29
Я вот не понимаю для чего вообще понадобилось лезть в эту процедуру.... Бред какой-то. Обычно ломают/расширяют либо саму подключенную команду, либо корректируют список подключенных команд (подменяют одни другими или удаляют какие-либо команды, меняют порядок). Но вот чтобы лезть в обработчик выполнения команды...
   Cyberhawk
 
22 - 20.11.18 - 11:35
(21) Так пади режим совместимости не позволяет ОМ расширить, а модуль формы - позволяет
   Geroy
 
23 - 20.11.18 - 11:39
(21) (22) зачем мне общий модуль, повторюсь мне нужно отловить выполнение команды и не прерывать её, а просто выполнить некоторые действия. Нужно отловить перед созданием на основании Заказа Клиента.

Задача выполнена.

&НаКлиенте
&Перед("Подключаемый_ВыполнитьКоманду")
Процедура Расш_Подключаемый_ВыполнитьКоманду(Команда)
    Если Команда.Имя = "ПодменюСоздатьНаОснованииОбычное_СоздатьНаОснованииЗаказа" Тогда    
        //Мой код

    КонецЕсли;
            
КонецПроцедуры
   Cyberhawk
 
24 - 20.11.18 - 11:40
Ну то есть ты директиву компиляции не поставил, из-за этого не работало


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует