Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как выделить в 12.34.56.78 числа?

Как выделить в 12.34.56.78 числа?
Я
   yohuyike
 
18.11.18 - 19:24
Как выделить в 12.34.56.78 числа?
 
 
   Lexey_
 
1 - 18.11.18 - 19:26
(0) СтрРазделить()
   2S
 
2 - 18.11.18 - 19:26
Кодом в 3 строчки
   trad
 
3 - 18.11.18 - 19:27
Целые?
   trad
 
4 - 18.11.18 - 19:27
(3) к (0)
   yohuyike
 
5 - 18.11.18 - 19:28
(1) Это я знаю. А специальные функции?
   yohuyike
 
6 - 18.11.18 - 19:28
(3) Целые
   Lexey_
 
7 - 18.11.18 - 19:28
(5) какие такие специальные?
   yohuyike
 
8 - 18.11.18 - 19:30
(7) Готовые
   Lexey_
 
9 - 18.11.18 - 19:31
(8) в (1) готовая функция, что тебе еще надо?
   Chameleon1980
 
10 - 18.11.18 - 20:37
как говорят "к такому меня жизнь еще не готовила".

да кто-ж знал-то, что тебе приспичит. А так бы да - обязательно бы написали типовые функции для тебя вот специально.
 
 Рекламное место пустует
   RedEchidna
 
11 - 19.11.18 - 04:14
Как-то так?
масЧисла = ВыделитьЧисла("12.34.56.78");

Процедура ВыделитьЧисла(стрНеЧисло)
    Возврат СтрРазделить(стрНеЧисло, ".");
КонецПроцедуры;
   craxx
 
12 - 19.11.18 - 05:32
(11) забыли обойти потом массив в цикле и привести значения к числовым
   RedEchidna
 
13 - 19.11.18 - 05:38
(12) Согласен, поторопился. Еще и процедура вместо функции.

Функция ВыделитьЧисла(стрНеЧисло)
    масСтроки = СтрРазделить(стрНеЧисло, ".");
    масЧисла = Новый Массив;
    Для Каждого элМассива Из масСтроки Цикл
        масЧисла.Добавить(Число(элМассива));
    КонецЦикла
    Возврат масЧисла;
КонецФункции;
   craxx
 
14 - 19.11.18 - 05:41
(13) ну и после КонецФункции не надо точки с запятой

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует