Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как добавит ь отбор по новой колонке в форме списка обыч прилож

Как добавит ь отбор по новой колонке в форме списка обыч прилож
Я
   1сЮлия
 
16.11.18 - 15:38
Все работает,кроме отбора,колонка добавляется.  
процедура ПриОткрытии()
     ЭлементСписок = ЭлементыФормы.Список;
    Для Каждого ТекКолонка ИЗ ЭлементСписок.Колонки Цикл
        ТекПозиция = ЭлементСписок.Колонки.Индекс(ТекКолонка);
        Если ТекКолонка.Имя = "ВидОперации" Тогда
            НовКолонка = ЭлементСписок.Колонки.Вставить(ТекПозиция + 1);
            НовКолонка.Имя = "Сумма";
            НовКолонка.ТекстШапки = "Сумма";
            НовКолонка.Ширина = 10;
        КонецЕсли;
    КонецЦикла ;
    СписокОтбора = Новый СписокЗначений;
    ДокументСписок.Отбор.Добавить(Сумма);
    ДокументСписок.Отбор.Сумма.ВидСравнения = ВидСравнения.Равно;
    ДокументСписок.Отбор.Сумма.Использование = Истина; 
КонецПроцедуры
 
 
   Lexey_
 
1 - 16.11.18 - 15:47
(0) если колонка вычисляемая, то только по списку ссылок
   1сЮлия
 
2 - 16.11.18 - 15:48
это как ?
   Lexey_
 
3 - 16.11.18 - 15:51
(2) получить список документов(или что там у тебя) с нужной суммой, установить отбор по Ссылка с видом сравнения ВСписке
   Lexey_
 
4 - 16.11.18 - 15:52
(2) но вообще, правильный ответ в сообщении 2 здесь Как обратиться из формы списка дока к таб.части дока.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует