Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Работа с мобильного устройства

Работа  с мобильного устройства
Я
   Игорь_МММ
 
16.11.18 - 12:58
Попробовал в свойствах конфы установить галку "Назначение использования: мобильное устройство". Получил, что Такси не может использоваться на мобильном устройстве, только совместимость с 8.2. Понимаю так что заходя в опубликованную базу с мобильного, пользователь увидит интерфейс 8.2 и не увидит того, что мне надо - а именно : центра оповещений. Все так плохо)?
 
 
   Остап Сулейманович
 
1 - 16.11.18 - 13:00
(0) ГЫ.
"заходя в опубликованную базу с мобильного, пользователь увидит интерфейс 8.2"

Не увидит. Даже 8.2. Там свой интерфейс.
   Игорь_МММ
 
2 - 16.11.18 - 13:02
(1) что за "свой интерфейс"? откуда он берется?
ПС. не мобильное приложение имею ввиду
   Остап Сулейманович
 
3 - 16.11.18 - 13:08
(2) "не мобильное приложение имею ввиду"
А тогда что? И как тогда понимать "опубликованную базу"?
Имеется ввиду работа в браузере? Если так - можешь пилить и в таксях. В браузере оно одинаково.
   Остап Сулейманович
 
4 - 16.11.18 - 13:10
+ (3) "свой интерфейс" генерится мобильной платформой на базе описалова. А описалово видимо строится только на основе турбомилк. И не строится на основе таксей.
   Остап Сулейманович
 
5 - 16.11.18 - 13:14
+ (3) Если не мобильная платформа - тогда задлянафига чего то трогал в "назначении использования"? Оно там только для контроля синтаксиса. Что б выругаться если будешь пытаться использовать чего-нибудь чего использовать нельзя. Например планы счетов. (мобильная платформа пользует только регистры). Или будешь пытаться настройки СКД выводить на формы. Только для этого. Ни на какие интерфейсные бантики оно не влияет.
   Игорь_МММ
 
6 - 16.11.18 - 13:17
(3) именно - через браузер. спс, успокоил)
а как понять с какого устройства зашли в систему? не могу такой функции найти
   Allinna
 
7 - 16.11.18 - 13:44
интересно
   Игорь_МММ
 
8 - 16.11.18 - 14:36
апп...
хотелось бы модифицировать формы если человек заходит с мобильного (убрать видимость элементов, к примеру). Как определить с мобильного или не с мобильного зашел человек?
   ikea
 
9 - 16.11.18 - 15:23
(8)
#Если МобильноеПриложениеКлиент Тогда


#Иначе

#КонецЕсли
   Игорь_МММ
 
10 - 16.11.18 - 15:42
(9) мобильное приложение и просто вход через браузер с мобильного - разве не разные вещи?
 
 Рекламное место пустует
   edem911
 
11 - 16.11.18 - 15:51
(10) Так используй директивы Вебклиент и  МобильноеПриложениеКлиент соответсвенно
   Игорь_МММ
 
12 - 16.11.18 - 15:55
(11) МобильноеПриложение при чем? никак не въеду ... Это же отдельная песня совсем не одно и тоже что вход с мобильного устройства
   Остап Сулейманович
 
13 - 16.11.18 - 17:13
(12) Я делал так :
ЭтоТСД = Ложь;
Экраны = ПолучитьИнформациюЭкрановКлиента();
Для Каждого Экран Из Экраны Цикл
  Если (Экран.Высота < 600 И Экран.Ширина < 800) ИЛИ
(Экран.Высота < 800 И Экран.Ширина < 600) Тогда
    Режим = РежимОсновногоОкнаКлиентскогоПриложения.ПолноэкранноеРабочееМесто;        КлиентскоеПриложение.УстановитьРежимОсновногоОкна(Режим);
    ЭтоТСД = Истина;
    Прервать;
  КонецЕсли;
КонецЦикла;

Есть еще директива #Если ВебКлиент

Но оно отработает и на 32-дюймовом мониторе и на экране планшета
   Игорь_МММ
 
14 - 16.11.18 - 19:23
(13) спс

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует