Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

В подборе надо добавить фильтр по номенклатуре.

В подборе надо добавить фильтр по номенклатуре.
Я
   SkillUp
 
14.11.18 - 14:52
Как более правильно? Передаю список номенклатуры, с которым должна открываться форма. Делаю так:

Процедура ДействиеПодбор(ТабличнаяЧасть)
...

    СтруктураПараметровПодбора.Вставить("УсловиеПродаж"        , УсловиеПродаж);
    СтруктураПараметровПодбора.Вставить("ЕстьСкладВТабличнойЧасти", ЕстьСкладВТабличнойЧасти);
    СтруктураПараметровПодбора.Вставить("ВременныеТаблицы",ОбработкаТабличныхЧастей.СтруктураДляРасчетаРезерваПриПодбореНоменклатуры(ЭтаФорма, Истина, "Сделка"));
    //ТУТ!!!!

    Если ДоговорКонтрагента.Спецификация.Количество() > 0 Тогда
        Список = Новый СписокЗначений;
        Для Каждого Стр ИЗ ДоговорКонтрагента.Спецификация Цикл
            Список.Добавить (Стр.Номенклатура);
        КонецЦикла;
        СтруктураПараметровПодбора.Вставить("номенклатура",Список);
    КонецЕсли;
    
    РаботаСДиалогами.ОткрытьПодборНоменклатуры(ЭтаФорма, СтруктураПараметровПодбора, Метаданные());

КонецПроцедуры// ДействиеПодбор()
 
 
   ДенисЧ
 
1 - 14.11.18 - 14:53
Работает?
   SkillUp
 
2 - 14.11.18 - 14:55
(1) нет.
   Михаил Козлов
 
3 - 14.11.18 - 14:58
А процедура ОткрытьПодборНоменклатуры что-нибудь знает про список в СтруктуреПараметров.номенклатура?
   SkillUp
 
4 - 14.11.18 - 15:06
(3) В СтруктуреПараметров.номенклатура список есть, но вот как этот список, в фильтр по номенклатуре сделать?
   Михаил Козлов
 
5 - 14.11.18 - 15:39
(4) Попробовать наложить фильтр на таблицы подбора. Если это обычные формы, то в соответствующей форме несколько таблиц.
Либо модифицировать запросы, которые получают данные для подбора.
   SkillUp
 
6 - 14.11.18 - 15:51
(5) О! отлично. СП!
   AlvlSpb
 
7 - 14.11.18 - 16:02
ЗначениеОтбора = Новый Структура("номенклатура",Список);
ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);
ОткрытьФорму("НужнаяФорма", ПараметрыВыбора);
   SkillUp
 
8 - 14.11.18 - 18:36
(7) "Биг" СП! )
   SkillUp
 
9 - 14.11.18 - 18:40
СПАСИБО! )) --- А не СП)))) САМ СМЕЮСЬ ОТ ТОГО, ЧТО НАПИСАЛ ))))))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует