Вход | Регистрация



Сортировка списка документов

Сортировка списка документов
Я
   offroad11
 
12.11.18 - 13:06
Привет, как бы вы отсортировали список документов по реквизиту реквизита? Уточню, что это не динамический список, а обычное приложение с обычным элементом формы.
 
 
   formista2000
 
1 - 12.11.18 - 13:07
(0) Всё равно, я бы - запросом.
   FIXXXL
 
2 - 12.11.18 - 13:08
(0) а что за реквизит? сделал бы отбор, как вариант
   offroad11
 
3 - 12.11.18 - 13:14
(2) например добавил новый справочник "статус документа" и в справочнике реквизит "очередность" и хочу отсортировать по очереди статуса
   offroad11
 
4 - 12.11.18 - 13:18
(1) как то стало представляю как это сделать?
   catena
 
5 - 12.11.18 - 13:20
Я бы сделала динамический список.
   offroad11
 
6 - 12.11.18 - 13:22
(5) понимаешь, если идти через такой вариант решения, обрекаешь себя на то что бы переделать каждый список документов, куда добавляешь статус. конфигурация весьма не стандартная с кучей дополнительных колонок, которые не являются реквизитами.
   formista2000
 
7 - 12.11.18 - 13:27
(6) Пилите, Шура, пилите! (с)
   offroad11
 
8 - 12.11.18 - 13:29
(7) у меня единственная идея была сделать доп реквизит в самом документе "очередь статуса" и сортировать уже по нему, но если пользователь изменить очередность статуса в будущем. то уже не будет работать, а перезаписывать документы не вариант.
   Serg_1960
 
9 - 12.11.18 - 13:31
(6) Плюнь ты на список документов :) Лучше научи пользователей пользоваться отчетами - они лучше для показа хотелок юзверей, чем штатные списки документов.
   catena
 
10 - 12.11.18 - 13:46
(6)Динамические списки намного удобнее, так что, повод начать переводить. Тем более, говорят, что на новых платформах ОФ потихоньку дохнут.
 
 Рекламное место пустует
   offroad11
 
11 - 12.11.18 - 13:51
(10) да, это я уже заметил, что на последней платформе ОФ работают не адекватно. но по скольку уже понавесили кучу обвеса на список, переделывать за другими, желания мало. по этому надеялся и надеюсь найти обходной путь
   Повелитель
 
12 - 12.11.18 - 14:06
(0)
Процедура УстановитьСортировкуПоВсемуСписку(ЭлементФормы) Экспорт
        Для каждого Состав Из ЭлементФормы.НастройкаПорядка Цикл
            Если Состав.Имя = "Ссылка" Или
                Состав.Имя = "ПометкаУдаления" или
                Состав.Имя = "Предопределенный" или
                Состав.Имя = "ОтражатьВУправленческомУчете" или
                Состав.Имя = "ОтражатьВБухгалтерскомУчете" или
                Состав.Имя = "Проведен" Тогда
            Иначе
                Состав.Доступность = Истина;
            КонецЕсли;
        КонецЦикла;
    КонецПроцедуры// УстановитьСортировкуПоВсемуСписку()
   Повелитель
 
13 - 12.11.18 - 14:07
(12)
Процедура ПриОткрытии()
    УстановитьСортировкуПоВсемуСписку(ЭлементыФормы.СправочникСписок);
КонецПроцедуры
   offroad11
 
14 - 12.11.18 - 14:16
(13) (12) если честно не понял, как это может помочь в моей ситуации
   Повелитель
 
15 - 12.11.18 - 14:30
(14) Решает твою задачу в (0)
https://yadi.sk/i/boNCCcUjo_iRxw
   Повелитель
 
16 - 12.11.18 - 14:31
(14) Вчитался в вопрос )) 
Я не то предложил ))
   youalex
 
17 - 12.11.18 - 14:41
Если категорически не хочешь (5) или (7), есть еще ТЗ. Точнее, ТЧ, обработки, например.
   offroad11
 
18 - 12.11.18 - 14:46
(17) подробнее пожалуйста?
   Serg_1960
 
19 - 12.11.18 - 14:52
Запрос --> в ТЗ --> на ТЧ. И большая кнопка "Обновить" :)
   offroad11
 
20 - 12.11.18 - 14:56
(19) ну это же жесть
   FIXXXL
 
21 - 13.11.18 - 08:41
(20) тогда УФ делай


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует