Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как вывести план счетов на печать в 1С 7.7 Бухгалтерия?

v7: Как вывести план счетов на печать в 1С 7.7 Бухгалтерия?
Я
   Косяк
 
12.11.18 - 11:31
Не нашел как это сделать.
 
 
   VladZ
 
1 - 12.11.18 - 11:34
(0) А если нажать на букву "Я" права?
   Косяк
 
2 - 12.11.18 - 11:37
(1) я вас не понял
   АгентБезопаснойНацио
 
3 - 12.11.18 - 11:47
(0) в комплексной есть кнопка. если в бухии нет - возьми из комплексной
   Косяк
 
4 - 12.11.18 - 11:55
(3)У нас именно бухия.
   Косяк
 
5 - 12.11.18 - 11:56
(3)Если есть код вывода плана счетов из комплексное, запостите сюда пожалуйста
   Базис
 
6 - 12.11.18 - 11:59
Для Сч = 1 По 999 Цикл
 Если есть счёт с таким номером, то вывести
  Если есть субсчета то вывести отдельной процедурой
  КонецЕсли
 КонецЕсли
КонецЦикла
   Кац
 
7 - 12.11.18 - 12:00
выборкой же

Сч.ВыбратьСчета();
Пока Сч.ПолучитьСчет() = 1 Цикл
...
   АгентБезопаснойНацио
 
8 - 12.11.18 - 12:00
(5)////////////////////////////////////////////////////////////////////////////////

// ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ
//

//******************************************************************************
// ПечатьПланаСчетов()

//
// Параметры:

//  Нет.
//

// Возвращаемое значение:
//  Нет.

//
// Вызывается из формул элементов диалога:

//    Кнопка "Печать".
//

// Описание:
//  Формирует печатную форму плана счетов.

//
Процедура ПечатьПланаСчетов()
    
    Перем Стиль;
    
    Меню = СоздатьОбъект("СписокЗначений");
    Меню.ДобавитьЗначение(0, "Простой список");
    Меню.ДобавитьЗначение(1, "С подробными описаниями");
    
    Если Меню.ВыбратьЗначение(Стиль,,,,1) = 0 Тогда
        Возврат;
    КонецЕсли;
    
    Сч = СоздатьОбъект("Счет");
    Сч.ИспользоватьПланСчетов(ИспользоватьПланСчетов());
    
    Таблица = СоздатьОбъект("Таблица");
    Таблица.ИсходнаяТаблица("Описание");
    
    Таблица.ВывестиСекцию("Отчет");
    
    Сч.ВыбратьСчета();
    Пока Сч.ПолучитьСчет() = 1 Цикл
        Состояние("Обрабатывается счет: "+ Сч);
        
        Если Сч.ЭтоГруппа() = 1 Тогда
            Таблица.ВывестиСекцию("Группа");
        Иначе
            Таблица.ВывестиСекцию("Строка");
        КонецЕсли;
        
        Если Стиль = 1 Тогда
            ИмяСекции = СтрЗаменить(Сч.Код, ".", "_");
            
            Попытка
                Таблица.ВывестиСекцию(ИмяСекции);
                Таблица.ВывестиСекцию("Пробел");
                
                Высота = Таблица.ВысотаТаблицы();
                Таблица.Область(Высота, 2, Таблица.ВысотаТаблицы(), 2).РамкаОбвести(2,2,2,2);
                Таблица.Область(Высота, 3, Таблица.ВысотаТаблицы(), 10).РамкаОбвести(2,2,2,2);
                
            Исключение
            КонецПопытки;
        КонецЕсли;
    КонецЦикла;
    
    Таблица.ТолькоПросмотр(1);
    Таблица.Опции(0,0,2,0);
    Таблица.Показать("План счетов");
    
КонецПроцедуры// ПечатьПланаСчетов()
   Ёпрст
 
9 - 12.11.18 - 12:00
//******************************************************************************

// ПечатьПланаСчетов()
//

// Параметры:
//  Нет.

//
// Возвращаемое значение:

//  Нет.
//

// Вызывается из формул элементов диалога:
//    Кнопка "Печать".

//
// Описание:

//  Формирует печатную форму плана счетов.
//

Процедура ПечатьПланаСчетов()
    
    Перем Стиль;
    
    Меню = СоздатьОбъект("СписокЗначений");
    Меню.ДобавитьЗначение(0, "Простой список");
    Меню.ДобавитьЗначение(1, "С подробными описаниями");
    
    Если Меню.ВыбратьЗначение(Стиль,,,,1) = 0 Тогда
        Возврат;
    КонецЕсли;
    
    Сч = СоздатьОбъект("Счет");
    Сч.ИспользоватьПланСчетов(ИспользоватьПланСчетов());
    
    Таблица = СоздатьОбъект("Таблица");
    Таблица.ИсходнаяТаблица("Описание");
    
    Таблица.ВывестиСекцию("Отчет");
    
    Сч.ВыбратьСчета();
    Пока Сч.ПолучитьСчет() = 1 Цикл
        Состояние("Обрабатывается счет: "+ Сч);
        
        Если Сч.ЭтоГруппа() = 1 Тогда
            Таблица.ВывестиСекцию("Группа");
        Иначе
            Таблица.ВывестиСекцию("Строка");
        КонецЕсли;
        
        Если Стиль = 1 Тогда
            ИмяСекции = СтрЗаменить(Сч.Код, ".", "_");
            
            Попытка
                Таблица.ВывестиСекцию(ИмяСекции);
                Таблица.ВывестиСекцию("Пробел");
                
                Высота = Таблица.ВысотаТаблицы();
                Таблица.Область(Высота, 2, Таблица.ВысотаТаблицы(), 2).РамкаОбвести(2,2,2,2);
                Таблица.Область(Высота, 3, Таблица.ВысотаТаблицы(), 10).РамкаОбвести(2,2,2,2);
                
            Исключение
            КонецПопытки;
        КонецЕсли;
    КонецЦикла;
    
    Таблица.ТолькоПросмотр(1);
    Таблица.Опции(0,0,2,0);
    Таблица.Показать("План счетов");
    
КонецПроцедуры// ПечатьПланаСчетов()
   Davalebor
 
10 - 12.11.18 - 12:18
В бухе типовой есть же кнопка "Печать" в форме плана счетов
 
 Рекламное место пустует
   Косяк
 
11 - 12.11.18 - 13:50
Всем спасибо за помощь! Сделал отчет выводящий план счетов.
   Гад
 
12 - 12.11.18 - 13:52
принттскирн сделай и распечатай

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует