Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

не работает подбор физ.лиц УПП 1.3

не работает подбор физ.лиц УПП 1.3
Я
   skupidom
 
12.11.18 - 11:11
Из формы не типовго документа вызываю подбор по кнопке:
Процедура КоманднаяПанельПодбор()    
    ОткрытьФормуВыбораФЛ(ЭлементыФормы.ДопДниБольничныхОтпусковСотрудников,ЭтотОбъект,Ложь);               
КонецПроцедуры

Процедура ОткрытьФормуВыбораФЛ(Владелец,Ключ,ЗакрыватьПриВыборе) Экспорт    
СтандартнаяОбработка = Ложь;    
Форма = Справочники.ФизическиеЛица.ПолучитьФормуВыбора(,Владелец,Ключ);
Форма.ЗакрыватьПриВыборе = ЗакрыватьПриВыборе;
Форма.Заголовок = "Выберите Физических лиц: ";
Форма.Открыть();
КонецПроцедуры
  
В справочнике ФизическиеЛица в форме выбора написал процедуру
Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
ОповеститьОВыборе(ЗначениеВыбора.Ссылка);    
КонецПроцедуры

В итоге выбор не отрабатывает и отладчик не заходит в ОбработкаВыбора
 
 
   skupidom
 
1 - 12.11.18 - 11:27
если написать в форме списка физических лиц процедуру
ОповеститьОВыборе(ЗначениеВыбора.Ссылка); 
при попытке открытия карточки физ.лица из формы списка сразу закрывается справочник
   skupidom
 
2 - 12.11.18 - 12:55
неделю назад еще работало, а что случилось сейчас непонятно
   FIXXXL
 
3 - 12.11.18 - 13:05
(0) ты право-лево перепутал :)
ОбработкаВыбора (ChoiceProcessing)

Синтаксис:

ОбработкаВыбора(<ВыбранноеЗначение>, <СтандартнаяОбработка>) 

Описание:

Вызывается после выполнения выбора из другой формы.

ее нужно использовать в исходной форме, а не в форме выбора
   skupidom
 
4 - 12.11.18 - 13:20
сделал все в 1 форме документа куда должен подтягивать подбор:
Процедура ОткрытьФормуВыбораФЛ(Ключ,Владелец,ЗакрыватьПриВыборе) Экспорт
    
    СтандартнаяОбработка = Ложь;
    
    Форма = Справочники.ФизическиеЛица.ПолучитьФормуВыбора("ФормаВыбора",Владелец);
    Форма.Заголовок = "Выберите Физических лиц: ";
    Форма.ЗакрыватьПриВыборе = Ложь;
    Форма.МножественныйВыбор = Истина;
    Форма.Открыть();

КонецПроцедуры                                             

Процедура КоманднаяПанельПодбор()
    
    ОткрытьФормуВыбораФЛ(ЭлементыФормы.ДопДниБольничныхОтпусковСотрудников,ЭтотОбъект,Ложь);
               
КонецПроцедуры      

Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
    
    ОповеститьОВыборе(ЗначениеВыбора.Ссылка);

КонецПроцедуры
   skupidom
 
5 - 12.11.18 - 13:21
не работает,ОповеститьОВыборе не срабатывает, может все таки он должен быть  в процедуре выбора в форме выбора справочника ?
   Alexandr_U1982
 
6 - 12.11.18 - 13:45
(4)Замени "ЭтотОбъект" на "ЭтаФорма".
   FIXXXL
 
7 - 12.11.18 - 14:12
(4) вместо  ОповеститьОВыборе(ЗначениеВыбора.Ссылка);
напиши  Сообщить(ЗначениеВыбора.Ссылка);
и расскажи что сообщает
   skupidom
 
8 - 12.11.18 - 14:58
все получилось,спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует