Вход | Регистрация


Не работает сложная оплата из Розничной продажи в БП 3.0

Не работает сложная оплата из Розничной продажи в БП 3.0
Я
   Umga2002
 
10.11.18 - 19:33
Просматриваю код в документе Розничная продажа.
Вроде все заложено разработчиками.
А на деле
операция по эквайрингу не проходить, а проходит только чек из ККТ.

БП 3.0.65.72 Патформа 8.3.13.1513.

отдельно наличные и по платежной карте проходят нормально.

Может кто сталкивался.
Не хочется пилить конфу.
 
 
   Umga2002
 
1 - 11.11.18 - 14:04
может хоть что-то по сабжу
   Доминошник
 
2 - 11.11.18 - 18:29
Не пользовался, но вообще - должна проходить.

&НаСервере
Процедура УстановитьВидОплаты()

    Оплата.Загрузить(ПолучитьИзВременногоХранилища(Параметры.АдресТаблицаОплата));
    
    Если Оплата.Количество() = 0 Тогда
        
        ВидОплаты = "Наличные";
        
    ИначеЕсли Оплата.Количество() = 1 
            И Оплата[0].ВидОплаты.ТипОплаты = Перечисления.ТипыОплат.ПлатежнаяКарта 
            И Оплата[0].Сумма = СуммаДокумента Тогда 
            
        ВидОплаты = "Карта";
        
    Иначе
        
        ВидОплаты = "Другое";
        
    КонецЕсли;
    
    Элементы.ГруппаСтраницы.ТекущаяСтраница = Элементы["Страница"+ВидОплаты];

КонецПроцедуры


То есть количество оплат как-то нужно установить...
   Доминошник
 
3 - 11.11.18 - 18:32
Хотя, конечно, в этом

&НаКлиенте
Процедура РассчитатьСдачу()
    СуммаСдача = Макс(СуммаПолученоНаличными - СуммаДокумента, 0);
КонецПроцедуры


логика нарушена (на мой взгляд).
   Umga2002
 
4 - 12.11.18 - 13:20
В том то и дело что "логика" вроде заложена и Список оплат формируется

а на деле выползает чек ккм и все
эквайринговый терминал молчит и слипов нет

а в чеке ККМ все отражается верно.

Оттрассировать на рабочем месте нет возможности - Работают.
   Доминошник
 
5 - 12.11.18 - 16:12
(4) Т.е. в случае, если кассир говорит - "Оплата смешанная", чек ККМ выходит на полную сумму?
И в чеке разбивка по видам оплат - та, что указана кассиром?
А эквайринг говорит - денег нет?

Я всё правильно понял?
   Umga2002
 
6 - 12.11.18 - 16:27
Эквайрин ничего не говорит.

чек из ККМ ШТРИХ МФ02 пробивается правильно.
с разделение по наличными Безналичным.

В ленте закрытия смены тоже все правильно.
   Umga2002
 
7 - 13.11.18 - 16:31
апну Может еще кто скажет что-то?
   Garykom
 
8 - 13.11.18 - 16:40
Могу сказать что изучай код или пиши в техподдержку
   Umga2002
 
9 - 14.11.18 - 16:39
Видимо придется останавливать кассу и заниматься трассировкой.....

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует