Вход | Регистрация



ОбработкаПолученияПолейПредставления - не работает в документе

ОбработкаПолученияПолейПредставления - не работает в документе
Я
   sergiykooo
 
09.11.18 - 15:14
переопределяю представление, в справочнике все работает, а в документе - нет
 
 
   Полбатона
 
1 - 09.11.18 - 15:48
Продолжайте наблюдение
   Cyberhawk
 
2 - 09.11.18 - 15:50
Может, потому что документ не записан?
   sergiykooo
 
3 - 09.11.18 - 17:17
(2) Кажется вы не очень понимаете этот механизм. У меня реквизит - ссылка на документ и есть его стандартное представление, которое я хочу изменить. Конечно же я выбираю документы которые записаны, или ексть какие-то другие варианты?))
   sergiykooo
 
4 - 09.11.18 - 17:18
(1) вы очень помогли, спасибо
   vicof
 
5 - 09.11.18 - 17:21
(0) Ви таки может код выложите?
   Cyberhawk
 
6 - 09.11.18 - 17:26
(3) Мало ли где и что ты там выбираешь. Представление и для не записанного в БД объекта получается, если что.
   Полбатона
 
7 - 09.11.18 - 17:51
(3) кажется, тупенький, ты не знаешь, как правильно задавать вопросы. Если хочешь, дяденька тебя может научить за копеечку, а то так и помрешь дурачком.
   sergiykooo
 
8 - 12.11.18 - 11:04
(5)
например такой код:

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Поля.Добавить("Номер");
КонецПроцедуры

Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Представление = Данные.Номер;
КонецПроцедуры
   Fragster
 
9 - 12.11.18 - 11:09
(8) у меня такой код работает
   hhhh
 
10 - 12.11.18 - 11:11
(8) СтандартнаяОбработка =Истина;
 
 Рекламное место пустует
   PR
 
11 - 12.11.18 - 11:11
(0) Врешь
   sergiykooo
 
12 - 12.11.18 - 11:12
(9) на какой платформе?
   Fragster
 
13 - 12.11.18 - 11:14
(12) 8.3.10.2639, 8.3.12.1685
   Cyberhawk
 
14 - 12.11.18 - 11:14
(10) В его случае на результат влиять не должно, Истина там в первом методе или Ложь
   Fragster
 
15 - 12.11.18 - 11:15
меньше балуйтесь с динамическим обновлением
   Остап Сулейманович
 
16 - 12.11.18 - 11:16
(8) А ДляНафига в поля добавляется Номер? Он же и так в стандартных? В случае документа вот это :

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Поля.Добавить("Номер");
КонецПроцедуры

АбсолютноНенужнаяХрень.
   Fragster
 
17 - 12.11.18 - 11:18
(16) например чтобы не выбирать дату ;)
   sergiykooo
 
18 - 12.11.18 - 11:20
(16) это я для теста показал, на самом деле мне в представление нужно показать совсем другие данные
   Вафель
 
19 - 12.11.18 - 11:21
теперь скриншот кинь
   Остап Сулейманович
 
20 - 12.11.18 - 11:22
(17) "Представление = Данные.Номер;" - где здесь выбор даты?
   Fragster
 
21 - 12.11.18 - 11:23
(20) здесь - нет. а в ОбработкаПолученияПолейПредставления если не выключить стандартную обработку - будет.
   Cyberhawk
 
22 - 12.11.18 - 11:23
(20) Так он пишет "не выбирать". Штатно дата и номер выбираются, а если станд. обр. = Ложь (как в приведенном примере), то только номер будет тащиться из БД.
   Остап Сулейманович
 
23 - 12.11.18 - 11:25
(22) Типа офигенная экономия передаваемых в ОбработкаПолученияПредставления байт получится? Или где?
   Остап Сулейманович
 
24 - 12.11.18 - 11:29
+ (23) Я бы понял, если бы представление получалось типа
"Приходная накладная (поставщик : "СТВ") №10 от 01.01.2018 по договору "Проект №1""
Тогда бы - да из документа нужно было бы взять поставщика, описалово договора... Но городить огород с исключением из представления даты. Да потом спрашивать почему не работает - понять затрудняюсь.
   Cyberhawk
 
25 - 12.11.18 - 11:36
(24) Вроде у документа нет индекса, куда входит и дата, и номер, а вот по отдельности - есть
   sergiykooo
 
26 - 12.11.18 - 11:44
Все, вопрос решился, была подписка на событие для моего документа.
Ответ на предыдущие сообщения, меняю представления я не для экономии, а для вывода дополнительной информации


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует