Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Получить картинку из ХранилищаЗначений и вывести в СКД, в проц. -"ПриКомпоновкеРезультата"

Получить картинку из ХранилищаЗначений и вывести в СКД, в проц. -"ПриКомпоновкеРезультата"
Я
   SkillUp
 
09.11.18 - 12:04
В отчете -"ПрайсЛист", в процедуру "ПриКомпоновкеРезультата", пишу код чтоб вывести картинку из хранилища.

Последовательно, прохожу по всем ячейкам табличного документа и вывожу вместо ХранилицеЗначения соответствующую картинку.При выводе отчета, выводит пустые картинки... Благодарность за подсказку...

 Для ТекущаяСтрока = 1 По ДокументРезультат.ВысотаТаблицы Цикл

        Для ТекущаяКолонка = 1 По ДокументРезультат.ШиринаТаблицы Цикл

            ТекущаяОбласть = ДокументРезультат.Область(ТекущаяСтрока, ТекущаяКолонка);
            ТекущаяРасшифровка = ТекущаяОбласть.Расшифровка;

            Если ТипЗнч(ТекущаяРасшифровка) = Тип("ИдентификаторРасшифровкиКомпоновкиДанных") Тогда

                ПоляРасшифровки = ДанныеРасшифровки.Элементы.Получить(ТекущаяРасшифровка).ПолучитьПоля();
                ПолеКартинки = ПоляРасшифровки.Найти("Картинка");

                Если ТипЗнч(ПолеКартинки) = Тип("ЗначениеПоляРасшифровкиКомпоновкиДанных") Тогда

                    ФайлКартинки = ПолеКартинки.Значение;

                    Если ТипЗнч(ФайлКартинки) = Тип("ХранилищеЗначения") Тогда

                        КартинкаВДокументе = ДокументРезультат.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                        КартинкаВДокументе.Картинка = Новый Картинка(ФайлКартинки.Получить());
                        КартинкаВДокументе.РазмерКартинки = РазмерКартинки.Пропорционально;
                        КартинкаВДокументе.Расположить(ТекущаяОбласть);

                    КонецЕсли;

                КонецЕсли;

            КонецЕсли;

        КонецЦикла;

    КонецЦикла;
 
 
   SkillUp
 
1 - 09.11.18 - 12:07
Скорей всего, где-то тут не правильно:

 ФайлКартинки = ПолеКартинки.Значение;

                    Если ТипЗнч(ФайлКартинки) = Тип("ХранилищеЗначения") Тогда

                        КартинкаВДокументе = ДокументРезультат.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                        КартинкаВДокументе.Картинка = Новый Картинка(ФайлКартинки.Получить());
                        КартинкаВДокументе.РазмерКартинки = РазмерКартинки.Пропорционально;
                        КартинкаВДокументе.Расположить(ТекущаяОбласть);

                    КонецЕсли;
   Вафель
 
2 - 09.11.18 - 12:08
а в отладчике какой тип у ФайлКартинки ?
   Вафель
 
3 - 09.11.18 - 12:09
а картинки точно не в томах хранятся?
   SkillUp
 
4 - 09.11.18 - 12:09
(2) ХранилищеЗнач
   SkillUp
 
5 - 09.11.18 - 12:13
(3) не, не в томах.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует