Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

групповая обработка объектов

групповая обработка объектов
Я
   Aslay
 
09.11.18 - 11:08
Доброго дня. Артикул номенклатуры имеет кучу пробелов. Сделал отбор обработкой, вижу эти объекты, а какое выражение дописать чтоб удалить лишние пробелы? Артикулы типа такого - АА 01_____(где_ пробел)
 
 
   ДенисЧ
 
1 - 09.11.18 - 11:09
СокрЛП()
   Повелитель
 
2 - 09.11.18 - 11:10
СокрЛП(Объект.Артикул);
Объект.Записать();
   ZDenis
 
3 - 09.11.18 - 11:12
Так то обработку по поиску пробелов сложнее написать
   Aslay
 
4 - 09.11.18 - 15:40
Сделал проще. Выгрузил в эксель, наити" " с заменой на ""(пустое значение) и загрузил обработкои-загрузка с табличных данных.
   ZDenis
 
5 - 09.11.18 - 15:47
(4) с таким подходом у тебя и пробел между АА и 01 тоже пропал
   Cyberhawk
 
6 - 09.11.18 - 15:51
(5) Зато появился пробел в трудовой книжке )
   Maniac
 
7 - 09.11.18 - 15:53
Марафет номенклатуры в 1С - порядок в справочнике

https://subsystems.ru/solutions/1c_excel/marafet_nomenklatury_kompleks_obrabotok_po_navedeniyu_poryadka_v_spravochnike_ut10_ut11/

позволяет обработать как угодно номенклатуру добавляя любые алгоритмы.
   Полбатона
 
8 - 09.11.18 - 15:55
(7) реклама на форуме платная.
   Волшебник
 
9 - 09.11.18 - 15:58
(8) У него денег нет
   Maniac
 
10 - 09.11.18 - 15:59
Ок пишу бесплатно


Наименование = СтрЗаменить(Наименование,"  ","");
 
 Рекламное место пустует
   Maniac
 
11 - 09.11.18 - 15:59
Наименование = СтрЗаменить(Наименование,"  "," ");
   Cyberhawk
 
12 - 09.11.18 - 16:00
(10) Жестькакая
   Maniac
 
13 - 09.11.18 - 16:00
Наименование = СокрЛП(СтрЗаменить(Наименование,"  "," "));
   Волшебник
 
14 - 09.11.18 - 17:02
(13) Коллега, а Вы программировать умеете?
   GANR
 
15 - 09.11.18 - 17:15
(0) Если уж кодить - внешнюю обработку лучше нацарапать с нуля простенькую. Хоть отладить можно если что. А Выполнить("...") внутри этой групповой обработки или еще чего-то - отвратительно.
   Maniac
 
16 - 09.11.18 - 22:52
Открою серкет... таам есть уже встроенная обработка.
Групповое изменение реквизитов
   Злопчинский
 
17 - 09.11.18 - 23:03
(13) Я не знаю как в этом хитровывернутом снеговике, но в клюшках конструкция СтрЗаменить(Наименование,"  "," ") не приведет к полной замене двойных пробелов на одинарный.
   tesseract
 
18 - 09.11.18 - 23:07
(16) +1 Можно выполнить любой произвольный алгоритм.
   Maniac
 
19 - 09.11.18 - 23:11
(17) этот вопрос уже тысячу раз задавался, в гугла километры готовых вариантов.
Я просто дал самый простой)) но зато бесплатный!)
   Maniac
 
20 - 09.11.18 - 23:11
Я ж и не обещал что удалю все)
Но вполне себе достаточно если их всего два.
   Maniac
 
21 - 09.11.18 - 23:14
лана дарю

НаименованиеПосле = Наименование;
Пока Найти(НаименованиеПосле , "  ") > 0 Цикл
  НаименованиеПосле = СтрЗаменить(НаименованиеПосле ,"  "," ");
КонецЦикла;
Наименование = НаименованиеПосле;
   пипец
 
22 - 09.11.18 - 23:16
(21) Мань , два пробела не значит системный таб ))))))))))
   Злопчинский
 
23 - 09.11.18 - 23:16
Опередил, я тут как раз тест набрасывал...
в клюшках:

    //строка 10 пробелов

    ОдинПробел = " "; ДваПробела = "  "; СтрокаПробелов = "          ";
    
    Пока Найти(СтрокаПробелов,ДваПробела)>0 Цикл
        Сообщить("Пробелов в строке: "+СтрЧислоВхождений(СтрокаПробелов,ОдинПробел));
        СтрокаПробелов = СтрЗаменить(СтрокаПробелов,ДваПробела,ОдинПробел)
    КонецЦикла;

Пробелов в строке: 10
Пробелов в строке: 5
Пробелов в строке: 3
Пробелов в строке: 2
   пипец
 
24 - 09.11.18 - 23:18
(23) Злоп , ну ты ж фанат , все досконально )))) , так шо ничо
   пипец
 
25 - 09.11.18 - 23:18
еще осталось внесистемные символы выкинуть )
   Злопчинский
 
26 - 09.11.18 - 23:19
(24) я не фанат, но, как говорится "будь пердельно бздителен!"
   пипец
 
27 - 09.11.18 - 23:20
(26) Злоп , скока за тобой смотрю , не перестаю удивляться )))) широкой души человек
   Злопчинский
 
28 - 09.11.18 - 23:22
(25) ну, у меня на этот случай простенькая функция
глНормализоватьСтроку(ИсходнаяСтрока,НаборКривыхСимволов,СимволНормализатор)


Функция глНормализоватьСтроку(Знач Источник, Знач НормальныйШаблон="\/:*?""<>| ", Знач Нормализатор="#") Экспорт

    Если Найти(НормальныйШаблон,Нормализатор)<>0 Тогда Нормализатор = ""; КонецЕсли;
    Источник = СокрЛП(Источник);
    Дл = СтрДлина(НормальныйШаблон); Для ы=1 по Дл Цикл Источник = СтрЗаменить(Источник,Сред(НормальныйШаблон,ы,1),Нормализатор); КонецЦикла;
    Возврат Источник;
КонецФункции//глНормализоватьСтроку()
   Maniac
 
29 - 09.11.18 - 23:24
Ща погодите!!
я вам кое  что сделаю!
   Maniac
 
30 - 09.11.18 - 23:27
Блин фаайлообменниик подскаажите по обмену обработками
   пипец
 
31 - 09.11.18 - 23:29
не Мань , мене что то смущает , некая тенденция ы сообщениях , тождественная и реликтовое смещение к корню из минус одного )
   Maniac
 
32 - 09.11.18 - 23:31
а ладна. все равно у Злопа восьмерки нет!
   Злопчинский
 
33 - 09.11.18 - 23:32
(32) ну ты загнул!
 
 
   Злопчинский
 
34 - 09.11.18 - 23:33
ты лучше в 8-ке прогони тест из (23)
   Maniac
 
35 - 09.11.18 - 23:34
слишком много кода
   пипец
 
36 - 09.11.18 - 23:36
у Злопа 8-ка есть )))))))
   Злопчинский
 
37 - 09.11.18 - 23:42
(35) чё, стак оферфлоу? во что воьсмерка богомерзкая делает.. редуцирует по нехочу...
   Aslay
 
38 - 12.11.18 - 13:21
(5) (6) Искал с заменой 2 и более пробела. Если артикул А 01(1 пробел между), его не заменял. Так что однопробелные артикулы сохранились). Другое дело когда после 01 есть пробел.
   FIXXXL
 
39 - 12.11.18 - 13:23
(11) твоя поделка по этому принципу работает??? :)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует