Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Отчет по списку номенклатуры.

Отчет по списку номенклатуры.
Я
   Полька
 
09.11.18 - 07:58
Есть некий ограниченный список номенклатуры. Нужно получить отчет только по этому списку. Причем, список должен сохраняться и при вызове отчета в след. раз показываться. Пользователи могут этот список изменять.
То ли туплю :)) но никак не соображу- как делать. И пример готового отчета не могу вспомнить.
 
 
   Mankubus
 
1 - 09.11.18 - 08:02
(0)

СохранитьЗначение (SaveValue)
Синтаксис:

СохранитьЗначение(<Имя>, <Значение>)
Параметры:

<Имя> (обязательный)

Тип: Строка.
Имя, с которым сохраняется значение, используется для идентификации сохраняемых значений. 
<Значение> (обязательный)

Тип: Произвольный. 
Сохраняемое значение.
Описание:

Сохраняет значение для использования не только в текущем, но и в последующих сеансах работы с программой. Значение хранится индивидуально для каждой пары информационная база - пользователь. Например, можно сохранять значения по умолчанию, используемые данным пользователем.

Доступность:

Толстый клиент.
Пример:

СохранитьЗначение("СрокИсполненияЗаказа", СрокИсполнения);
СохранитьЗначение("СкладПоУмолчанию", МестоХранения);
 

См. также:

Глобальный контекст, метод ВосстановитьЗначение
   Галахад
 
2 - 09.11.18 - 08:07
Для типовых:
Процедура ПриЗакрытии()
    
    СтруктураНастройки = Новый Структура;
    СтруктураНастройки.Вставить("Пользователь", глЗначениеПеременной("глТекущийПользователь"));
    СтруктураНастройки.Вставить("ИмяОбъекта", Строка(ЭтотОбъект));
    СтруктураНастройки.Вставить("НаименованиеНастройки", "ффф");
    СтруктураНастройки.Вставить("СохраненнаяНастройка", Товары.Выгрузить());

    УниверсальныеМеханизмы.СохранитьНастройку(СтруктураНастройки);

КонецПроцедуры

Процедура ПриОткрытии()
    
    СтруктураНастройки = Новый Структура;
    СтруктураНастройки.Вставить("Пользователь", глЗначениеПеременной("глТекущийПользователь"));
    СтруктураНастройки.Вставить("ИмяОбъекта", Строка(ЭтотОбъект));
    СтруктураНастройки.Вставить("НаименованиеНастройки", "ффф");

    Если УниверсальныеМеханизмы.ПолучитьНастройку(СтруктураНастройки) Тогда
        Товары.Загрузить(СтруктураНастройки.СохраненнаяНастройка);
    КонецЕсли;
    
КонецПроцедуры
   Полька
 
3 - 09.11.18 - 12:53
Спасибо! :)
   Buster007
 
4 - 09.11.18 - 12:57
а просто флажок нельзя поставить "Сохранять значения"?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует