Вход | Регистрация


Проблема с обработчиками событий.

Проблема с обработчиками событий.
Я
   СинийКот
 
09.11.18 - 03:18
Здравствуйте. Начал изучать 1С, основные объекты и столкнулся с какой-то фигней.
Пишу обработчики событий в документе, в модуле ФормаДокумента:

&НаКлиенте
Процедура ТоварыКоличествоПриИзменении(Элемент)
    Стр = Элементы.Товары.ТекущиеДанные;
    Стр.Сумма = Стр.Количество * Стр.Цена;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьЦенуНоменклатуры(Номенклатура)
    Возврат Номенклатура.ЦенаПокупки;
КонецФункции

&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
    Стр = ПолучитьЦенуНоменклатуры(Стр.Номенклатура);
    ТоварыКоличествоПриИзменении(Элемент);
КонецПроцедуры

Запускаю 1С. Создаю ПоступлениеТоваров. ЦенаПокупки не подцепляется, сумма не рассчитывается. В чем может быть дело? Кучу видео и книг пересмотрел, все вроде делаю как у них...
 
 
   Полбатона
 
1 - 09.11.18 - 03:48
Не надо писать, надо создавать через редактор формы или через редактор модуля.
Тыкни на реквизит ТЧ и увидишь свои обработчики
   СинийКот
 
2 - 09.11.18 - 14:32
Ну так и создавал, через редактор формы документа, нажатием на свойства - ПриИзменении. Почему не работают-то? Может, что-то где-то не создал, не указал?..
   Cyberhawk
 
3 - 09.11.18 - 14:33
Так у тебя говнокод. Чего ты ожидал?
   RomanYS
 
4 - 09.11.18 - 14:34
//    Стр = ПолучитьЦенуНоменклатуры(Стр.Номенклатура);

    Стр = Элементы.Товары.ТекущиеДанные;
    Стр.Цена = ПолучитьЦенуНоменклатуры(Стр.Номенклатура);
   СинийКот
 
5 - 09.11.18 - 15:07
Да, сорри, эти две строчки пропустил - десятый раз перепечатываю. Но и с ними ничего не работает все равно, проверял уже. Сумму-то он должен по идее считать, а он не делает этого.
   Cyberhawk
 
6 - 09.11.18 - 15:28
Нужно расследование
   Очевидно
 
7 - 09.11.18 - 15:34
(0) а ты уверен что обновил свою конфигурацию, после написания этого "кода" ?
дело в том, что с подобной конструкцией как :
&НаКлиенте
Процедура ТоварыНоменклатураПриИзменении(Элемент)
    Стр = ПолучитьЦенуНоменклатуры(Стр.Номенклатура);
    ТоварыКоличествоПриИзменении(Элемент);
КонецПроцедуры

мне кажется у тебя форма документа открываться не должна ? (должна выпадать с ошибкой)
   RomanYS
 
8 - 09.11.18 - 15:41
(6) Расследовать почему ТС не может включить отладчик, может ему угрожают

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует