Вход | Регистрация


Мобильное приложене. Запуск apk.

Мобильное приложене. Запуск apk.
Я
   Rokstedi
 
08.11.18 - 17:30
Добрый день. Написал свой драйвер для сканера ШК + еще некоторые функции. Скомпилировал в .apk файл. В 1с добавил как общий макет. Хочу сделать чтобы можно было установить с 1с. Пробую через ЗапуститьПриложение() - ничего не происходит. Пробовал выполнение как на сервере так и на клиенте. Вот фрагмент кода:

&НаКлиенте
Процедура УстановитьДрайвер(Команда)
    
    #Если МобильноеПриложениеКлиент Тогда 

        СсылкаНаФайл = ПолучитьСсылкуНаДрайвер();
        ИмяФайлаВрем = "ДрайверСканера" + ".apk";
        ВременныйКаталог = КаталогВременныхФайлов();
        Если ПолучитьФайл(СсылкаНаФайл, ВременныйКаталог + ИмяФайлаВрем, Ложь) Тогда
            УстановитьДрайверНаСервере(ВременныйКаталог + ИмяФайлаВрем);
        Иначе
            ТекстОшибки = НСтр("ru='Ошибка установки драйвера.'");
            Сообщить(ТекстОшибки); 
        КонецЕсли;
    #КонецЕсли


КонецПроцедуры


&НаСервере
Процедура УстановитьДрайверНаСервере(Путь)
    
    #Если МобильноеПриложениеСервер Тогда 

        ЗапуститьПриложение(Путь, , Истина);
    #КонецЕсли

    
КонецПроцедуры

&НаСервере
Функция ПолучитьСсылкуНаДрайвер() Экспорт
    
    Возврат ПоместитьВоВременноеХранилище(ПолучитьОбщийМакет("ДрайверСканера"));
    
КонецФункции
 
 
   Вафель
 
1 - 08.11.18 - 17:33
мобильныеп компоненты пишутся вот так
   H A D G E H O G s
 
2 - 08.11.18 - 17:37
(0) Так всетаки Компонента или Сервис?
   Rokstedi
 
3 - 08.11.18 - 17:41
(2) извините, это отдельный сервис
   H A D G E H O G s
 
4 - 08.11.18 - 17:42
Просто если это Компонента - то, скорее всего это будет so файл в zip архиве с манифестом (не путать с Android манифест).
Если это Сервис - то для него служит ЗапускПриложенияМобильногоУстройства по package имени (тоесть, apk нужно сначало установить).
Ну и Драйвер передачи ШК в МобильноеПриложение(Клиент) уже написан, пользуйтесь

http://catalog.mista.ru/public/935589/
   H A D G E H O G s
 
5 - 08.11.18 - 17:43
(1) Дааа, вот так и пишутся мобильные компоненты (да и многое в ведроиде).
   Rokstedi
 
6 - 08.11.18 - 17:44
(4) Можно как то запустить установку? Приложение собираю сборщиком. В дальнейшем еще хочу реализовать обновление мобильного приложения.
   Вафель
 
7 - 08.11.18 - 17:45
разве на андроиде одни приложения имеют права устанавливать другие?
   Rokstedi
 
8 - 08.11.18 - 17:47
В демо конфигурации "Мобильная касса" устанавливается apk файл. Но у меня чего-то не взлетело и там
   H A D G E H O G s
 
9 - 08.11.18 - 17:48
(6) Думаю, нет.

"В дальнейшем еще хочу реализовать обновление мобильного приложения."
Купите google.console, заведите тестового пользователя и выкладывайте релизы для внутреннего тестирования.
Google.Play вам и обновит и протестирует на 11 устройствах, предоставит !Видео! тестирования полный Logcat.
   H A D G E H O G s
 
10 - 08.11.18 - 17:49
"предоставит !Видео! тестирования полный Logcat."->
предоставит !Видео! тестирования и полный Logcat.
 
 Рекламное место пустует
   H A D G E H O G s
 
11 - 08.11.18 - 17:50
Хоть Ведроид и полное днище в плане архитектуры в сравнении в Win, но, Google.Console просто адова имба. Я просто в шоке был от удобства дистрибьюции, тестирования, оформления.
   dumb851
 
12 - 09.11.18 - 09:44
КаталогВременныхФайлов замени на КаталогДокументов
   michael512
 
13 - 09.11.18 - 09:53
(7) Если права дать, то могут
   Rokstedi
 
14 - 12.11.18 - 17:43
(12) Помогло спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует