Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Представление поля в дин. списке

Представление поля в дин. списке
Я
   ssh2006
 
07.11.18 - 16:48
Нужно определенное поле дин списка (ссылочное) выводить с кастомным представлением. Есть какие есть варианты кроме
ОбработкаПолученияПолейПредставления
Обработчик ПриПолученииДанныхНаСервере дин списка ?
 
 
   Вафель
 
1 - 07.11.18 - 16:51
Если представление = значению реквизита, то можно прям в запросе
   ssh2006
 
2 - 07.11.18 - 16:56
(1) Значение должно остаться значением, но визуально должно быть представлено иначе чем стандартно сформированное.
В отчетах на СКД представление настраивается в схеме. В дин списке такого нет.
   Cyberhawk
 
3 - 07.11.18 - 16:57
УО может?
   Вафель
 
4 - 07.11.18 - 16:59
(2) значение пожно в скрытх полях получать
   ssh2006
 
5 - 07.11.18 - 17:04
(3) да, где то подойдет, например сделать представлением просто какой то реквизит этой ссылки, а вот выражение типа "Док.Номер" + " от " + Формат(Дата, "...") не получается
   Cyberhawk
 
6 - 07.11.18 - 17:14
Если ты хочешь, чтоб было как в табличном документе (видишь одно, а по факту там сидит ссылка, щелкнув по которой открывается объект БД), то в ДС нужно для этого кодить (обработку выбора, например)
   ssh2006
 
7 - 08.11.18 - 17:49
Сделал так:

&НаСервереБезКонтекста
Процедура ОбщаяТаблица(ИмяЭлемента, Настройки, Строки)
        
    Для Каждого СтрокаСписка Из Строки Цикл 
        СтрокаСписка.Значение.Оформление["ЗаявкаПриОтправке"].УстановитьЗначениеПараметра("Текст", "Заявка " + СтрокаСписка.Значение.Данные.ЗаявкаПриОтправкеНомер);
    КонецЦикла;
    
КонецПроцедуры
   ssh2006
 
8 - 08.11.18 - 17:50
&НаСервереБезКонтекста
Процедура ОбщаяТаблицаПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)
        
    Для Каждого СтрокаСписка Из Строки Цикл 
        //СтрокаСписка.Значение.Оформление["ЗаявкаПриОтправке"].УстановитьЗначениеПараметра("Текст", "Заявка " + СтрокаСписка.Значение.Данные.ЗаявкаПриОтправкеНомер + " от " + Формат(СтрокаСписка.Значение.Данные.ЗаявкаПриОтправкеДата, "ДФ=dd.MM.yy"));

        СтрокаСписка.Значение.Оформление["ЗаявкаПриОтправке"].УстановитьЗначениеПараметра("Текст", "Заявка " + СтрокаСписка.Значение.Данные.ЗаявкаПриОтправкеНомер);
    КонецЦикла;
    
КонецПроцедуры
   ssh2006
 
9 - 08.11.18 - 17:52
Поле ЗаявкаПриОтправкеНомер не отображается в ДС, но установлена галка Использовать всегда чтобы обращаться к нему в обработчике

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует