Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1с мобильное приложение + ТСД

1с мобильное приложение + ТСД
Я
   men47
 
06.11.18 - 11:30
Привет всем! Нужна помощь, есть ТСД и есть самописное мобильное приложение. У ТСД есть своя механическая клавиатура и она прекрасно работает, пока не выбираем заполнение реквизита типа "Число". Когда выбираем тип Число, вылазит 1с-овская клавиатура и мобильное приложение требует ввод именно с нее, а клиент хочет, чтобы вводилось в поле типа "Число" именно с механической клавиатуры. Можно, конечно, перевести данное поле в тип "Строка", но хотелось бы, чтобы заработало именно в данном типе. Может кто сталкивался с данной проблемой?
 
 
   DmitrO
 
1 - 06.11.18 - 12:11
Все этого хотят.
   men47
 
2 - 06.11.18 - 12:29
(1) ясно, понятно=(
   men47
 
3 - 06.11.18 - 13:51
Тогда другой вопрос.... создал специально отдельный реквизит типа "Строка". Пытаюсь сделать проверку, в событие ИзменениеТекстаРедактирования пишу следующий код:

&НаКлиенте
Функция ЕстьКириллица(ИсходнаяСтрока) Экспорт 
    ЕстьКириллица=ложь; 
    ИсходнаяСтрока=СокрЛП(ИсходнаяСтрока); 
    Если СтрДлина(ИсходнаяСтрока)>0 Тогда 
        Для Сч=1 по СтрДлина(ИсходнаяСтрока) Цикл 
            Символ = НРег(Сред(ИсходнаяСтрока, Сч, 1)); 
            Если Найти(ВРЕГ("абвгдеёжзийклмнопрстуфхцчшщъыьэюяqwertyuiopasdfghjklzxcvbnm<>,/?=+-_)(*&^%$#@!\|"), ВРЕГ(Символ)) Тогда 
                ЕстьКириллица=истина; 
            КонецЕсли; 
        КонецЦикла; 
    КонецЕсли; 
    
    Возврат ЕстьКириллица; 
КонецФункции

&НаКлиенте
Процедура ТоварыКоличествоСтрокаИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Текст2 = Текст;
    Если НЕ Элемент.ТекстРедактирования = "" И ЕстьКириллица(Прав(Текст2,1)) Тогда
        Текст= Лев(Текст,СтрДлина(Текст)-1);    
    КонецЕсли;
    ////Элемент.ТекстРедактирования = Текст;

    ////Объект.Товары.Получить(Элементы.Товары.ТекущаяСтрока).КоличествоСтрока =  Текст;

    //Элементы.Товары.ТекущиеДанные.КоличествоСтрока = Текст;

КонецПроцедуры




итого если оставить просто "Текст" ничего не происходит.
Если я ставлю Элемент.ТекстРедактирования = Текст; налетаю на ошибку не доступен для записи.
Если я пишу 2 следующие строчки, то в ТСД после этих строк выделяет всю строку, тем самым, если мы начинаем вводить текст, то стирается предыдущий текст. АвтоПодбор так же работает. Подскажите, как тогда изменить этот чертовый реквизит....
   ИС-2
 
4 - 06.11.18 - 14:39
хм, может свойство автовыбор не заполненго отключить?
   men47
 
5 - 06.11.18 - 14:41
(4) не могу менять свойство, программа не дает

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует