Вход | Регистрация



Как спросить в запросе, что ссылка пустая?

Как спросить в запросе, что ссылка пустая?
Я
   Мисти
 
04.11.18 - 14:37
выбор Когда Заявка.Основание.Пустая() - так ведь не сработает?
А как?
 
 
   palsergeich
 
1 - 04.11.18 - 14:38
Значение(Справочник(или Документ).ИмяСправочника(документа).ПустаяСсылка)
   palsergeich
 
2 - 04.11.18 - 14:39
Или передать параметром в запрос
   Мисти
 
3 - 04.11.18 - 14:50
Спасибо, добрый человек!
Еще простой вопрос - если документ вводится на основании, но по сути - надо его скопировать, как это рисуют покрасивше?
   Cyberhawk
 
4 - 04.11.18 - 14:56
Может быть автору проверка не на пустую ссылку нужна, а на битую?
   Мисти
 
5 - 04.11.18 - 15:06
на пустую.
   jsmith82
 
6 - 04.11.18 - 15:19
учитывай, что ещё может быть составной тип, который выдаст неопределено
   jsmith82
 
7 - 04.11.18 - 15:21
(3) Скопировать()
   Мисти
 
8 - 04.11.18 - 15:28
(7) Такое в модуле документа пишут?
   jsmith82
 
9 - 04.11.18 - 15:31
(8) не совсем понял. ты какую копию хочешь? копию документа-основания иного типа или копию документа того же типа?
может, в твоём случае ОбработкаЗаполнения()
   jsmith82
 
10 - 04.11.18 - 15:35
если надо программно создать документ, который вводится на основании, то
НовыйДокумент = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
НовыйДокумент.Заполнить(ДокументОснование);
НовыйДокумент.Записать (РежимЗаписиДокумента.Проведение);
 
 Рекламное место пустует
   Мисти
 
11 - 04.11.18 - 15:38
Так вот это "заполнить" - это я и пишу в модуле!
// Процедура - обработчик события "ОбработкаЗаполнения".

//
Процедура ОбработкаЗаполнения(Основание)
   jsmith82
 
12 - 04.11.18 - 15:43
(11) не, тогда используй ЗаполнитьЗначенияСвойств
   jsmith82
 
13 - 04.11.18 - 15:44
ЗаполнитьЗначенияСвойств(ЭтотОбъект, Основание, , "Дата, Проведен, ПометкаУдаления");
   jsmith82
 
14 - 04.11.18 - 15:45
ну и для строк таб. части тоже, если есть
   jsmith82
 
15 - 04.11.18 - 15:46
Для Каждого Стр Из Основание.Товары Цикл
НовСтр = ЭтотОбъект.Товары.Добавить();
ЗаполнитьЗначенияСвойств(НовСтр, Стр);
КонецЦикла;
   jsmith82
 
16 - 04.11.18 - 15:46
ну или ЭтотОбъект.Товары.Загрузить(Основание.Товары.Выгрузить());
   Мисти
 
17 - 04.11.18 - 15:49
О! "исключая свойства" - я про это забыла.
Спасибо!
   Мисти
 
18 - 04.11.18 - 17:51
Как через метаданные заполнить все табличные части?
   Мисти
 
19 - 04.11.18 - 19:09
Для каждого ТЧ из Метаданные.Документы.ЗаказПокупателя.ТабличныеЧасти Цикл
            ИмяТЧ = ТЧ.Имя;
            КолСтрок = ОснованиеКорректировка[ИмяТЧ].Количество();
            Для ии = 0  по КолСтрок-1 Цикл
                ЭтотОбъект[ИмяТЧ].Добавить();
                ЗаполнитьЗначенияСвойств(ЭтотОбъект[ИмяТЧ][ии],
ОснованиеКорректировка[ИмяТЧ][ии]);
            КонецЦикла;             
        КонецЦикла;
   Мисти
 
20 - 04.11.18 - 19:58
А как отсторнировать все движения через метаданные?
   Мисти
 
21 - 04.11.18 - 21:13
Для каждого ТаблицаДвижений Из МетаданныеДвижений Цикл
        ИмяТаблицы = ТаблицаДвижений.Имя;
        ДокументСтарый.Движения[ИмяТаблицы].Прочитать();
как узнать - регистр накопления или сведений?
   catena
 
22 - 05.11.18 - 06:26
(21)А что, документа "Сторнирование" под руками нет?

ДвиженияДокументаОснования = Основание.Метаданные().Движения;
Для Каждого МетаданныеРегистр Из ДвиженияДокументаОснования Цикл
    
        Если Метаданные.РегистрыСведений.Содержит(МетаданныеРегистр) Тогда
            // регистры сведений не сторнируем

            Продолжить; 
        КонецЕсли;    
        
КонецЦикла;


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует