Вход | Регистрация


Не срабатывает процедура при активизации строки

Не срабатывает процедура при активизации строки
Я
   TolstiyBeremenniy
 
02.11.18 - 09:44
В процедуре задан обработчик. Запускаю предприятие. Ставлю точку
останова. Первый раз запускается. Потом ставлю курсор на разные
строки, ПриАктивизацииСтроки уже не запускается.

она же всегда должна запускаться при смене, выборе других строк?


&НаКлиенте
Процедура ПользователиСписокПриАктивизацииСтроки(Элемент)
 
 
   TolstiyBeremenniy
 
1 - 02.11.18 - 09:46
В какой тогда мне процедуре ставить обработчик, что бы
он срабатывал, при установке курсора на разные, любые строки?
   TolstiyBeremenniy
 
2 - 02.11.18 - 09:50
Пока не отлавил точками останова такой процедуры!
   TolstiyBeremenniy
 
3 - 02.11.18 - 09:53
Почему они не срабатывают?
   Тихий омут
 
4 - 02.11.18 - 09:56
Может быть, смотришь обработчик другого списка? При первой остановке посмотри Элемент.Имя
   TolstiyBeremenniy
 
5 - 02.11.18 - 10:00
(4) Ну то есть по идее этой процедуры должно хватать?

&НаКлиенте
Процедура ПользователиСписокПриАктивизацииСтроки(Элемент)
   Rokford
 
6 - 02.11.18 - 10:03
(5)
Должно хватать.
&НаКлиенте
Процедура Реквизит1ПриАктивизацииСтроки(Элемент)
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "Сработала";
    Сообщение.Сообщить();
КонецПроцедуры

Что в процедуре делаешь? В СП есть примечание

Примечание:

В обработчике данного события нельзя использовать серверные методы формы с директивой компиляции &НаСервере.
   TolstiyBeremenniy
 
7 - 02.11.18 - 10:13
(6) Да с этим вроде разобрался.

Сейчас такой вопрос. На форме 2 списка.
Я заполняю поля на форме по данным из выбранной строки
из второго списка.

А данные во втором списке меняются в зависимости от выбранной строки в первом списке. И что то я это вот не
могу отловить.

В какой процедуре первого списка, мне отлавливать первую строку во втором динамическом списке? То есть Я не могу увидеть данные во втором динамическом списке. Где их получать на сервер передавать эту таблицу?
   Тихий омут
 
8 - 02.11.18 - 10:23
(7) Что-то непонятно мне. Есть два списка, Список1 и Список2. При активизации строки в списке Список1 должны измениться данные в списке Список2. Так?
   TolstiyBeremenniy
 
9 - 02.11.18 - 10:27
(8) я увидел что в процедуре

&НаСервереБезКонтекста
Процедура СписокЗаявокУИиСПриПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)


Можно отлавливать появляющиеся в ней данные.
то есть если в первом списке меняется строка, перевыбирается то есть.
То во втором списке появляются или не появляются данные
в зависимости от их наличия.

Подскажите что не так? Я хочу получить процедурой Тз
этого динамического списка. Но пишет что эта процедура не определена!!!!


&НаСервереБезКонтекста
Процедура СписокЗаявокУИиСПриПолученииДанныхНаСервере(ИмяЭлемента, Настройки, Строки)
    ТзИзСпискаЗаявокУИиС = Получить_ТЗ_Из_ДинамическогоСписка();
КонецПроцедуры

&НаСервере
Функция Получить_ТЗ_Из_ДинамическогоСписка()
    Схема               = Элементы.СписокЗаявокУИиС.ПолучитьИсполняемуюСхемуКомпоновкиДанных();
    Настройки           = Элементы.СписокЗаявокУИиС.ПолучитьИсполняемыеНастройкиКомпоновкиДанных();
    КомпоновщикМакета   = Новый КомпоновщикМакетаКомпоновкиДанных();
    МакетКомпоновки     = КомпоновщикМакета.Выполнить(Схема, Настройки, , , Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
    ТЗ              = Новый ТаблицаЗначений;
    ПроцессорВывода.УстановитьОбъект(ТЗ); 
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    Возврат ТЗ;
КонецФункции
   TolstiyBeremenniy
 
10 - 02.11.18 - 10:32
(9+) как это правильно использовать?
 
 Рекламное место пустует
   Тихий омут
 
11 - 02.11.18 - 10:32
(9) Из внеконтекстной процедуры/функции нельзя вызывать обычную.
   Тихий омут
 
12 - 02.11.18 - 10:33
(10) Похоже, ты пытаешься решить какую-то задачу способами, привычными по обычным формам, но неприменимыми в управляемых. Что ты дальше с этой ТЗшкой, полученной из дин. списка, хочешь делать, зачем она тебе?
   TolstiyBeremenniy
 
13 - 02.11.18 - 10:36
(12) мне важно получить первую строку этого динамического списка, и вывести её данные в поля на форме.

не пойму как это получить в какой процедуре, лучше.
   TolstiyBeremenniy
 
14 - 02.11.18 - 10:37
(11) А как правильно тогда вызвать эту процедуру мне?
Если её нужно мне вызывать из СписокЗаявокУИиСПриПолученииДанныхНаСервере
   Вафель
 
15 - 02.11.18 - 10:37
(13) так это можно же просто реквизиты настроить. без кода
   Тихий омут
 
16 - 02.11.18 - 10:38
(13) Первую? Не текущую, а именно первую? А если строк много и юзер прокручивает список, то всё равно именно самую верхнюю, а не текущую? Что-то в постановке задачи не так
   TolstiyBeremenniy
 
17 - 02.11.18 - 10:42
(16) Ну там же пусто. Или пусто, или появляются строки.
Никто ещё не выбрал что бы она стала текущей, по этому первую хотел.
   TolstiyBeremenniy
 
18 - 02.11.18 - 10:42
(16) Если он меняет потом строки, то это уже процедура
этого списка получает данные.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует