Вход | Регистрация


Проблемы с V83COMConnector

Проблемы с V83COMConnector
Я
   jsmith82
 
01.11.18 - 16:10
Моё почтение господа

Сервер 64, клиент 64
не работает обмен
недопустимая строка с указанием класса
зарегистрировал всё что можно
Делаю по Книга знаний: Вызов 32-битных COM-объектов на стороне 64-битного сервера 1С
Ноль результата
Куда ещё копнуть?
Благодарю
 
 
   jsmith82
 
1 - 01.11.18 - 16:10
   azernot
 
2 - 01.11.18 - 16:16
А если просто переустановить stup-ом нужный релиз платформы?
   jsmith82
 
3 - 01.11.18 - 16:25
не знаю.. вчера ставил последний релиз на втором сервере, та же ошибка
   jsmith82
 
4 - 01.11.18 - 16:25
ну т.е.
комп 64, сервер 64, клиент 64
как заставить работать com?
   palsergeich
 
5 - 01.11.18 - 16:28
   palsergeich
 
6 - 01.11.18 - 16:30
путь для регистрации чуть чуть другой нежели с 32 разрядной системой
   palsergeich
 
7 - 01.11.18 - 16:31
и да может портебоваться ребут
   jsmith82
 
8 - 01.11.18 - 16:31
ну а если у меня нет x86, а только 64?
   Вафель
 
9 - 01.11.18 - 16:35
%systemroot%\System32\regsvr32.exe comctrl.dll
   jsmith82
 
10 - 01.11.18 - 16:47
короче, удалил все приложения из служб компонентов
отменил регистрации
забубенил (9)
взлетело
спс!
 
 Рекламное место пустует
   МаленькийВопросик
 
11 - 01.11.18 - 17:22
Это случайно не 8.3.12??? Синхра мду зуп и бух???
   bvb
 
12 - 01.11.18 - 17:29
Вот тебе функция юзай прямо из обработки и не парься

Процедура Зарегистрировать_comcntr_dll ()
    
    #Если Не ВебКлиент Тогда

        
        
        ТекстКоманды = "regsvr32.exe /n /i:user /s comcntr.dll";
        
        КодВозврата = Неопределено;
        ЗапуститьПриложение(ТекстКоманды, КаталогПрограммы(), Истина, КодВозврата);
        
        Если КодВозврата = Неопределено Или КодВозврата > 0 Тогда
            
            ТекстСообщения = НСтр("ru = 'Ошибка при регистрации компоненты comcntr.'") + Символы.ПС
            + НСтр("ru = 'Код ошибки regsvr32:'") + " " + КодВозврата;
            
            Если КодВозврата = 5 Тогда
                ТекстСообщения = ТекстСообщения + " " + НСтр("ru = 'Недостаточно прав доступа.'");
            КонецЕсли;
            
            
            //ПоказатьПредупреждение(,ТекстСообщения + Символы.ПС + НСтр("ru = 'Подробности см. в Журнале регистрации.'"));

        КонецЕсли;
        
    #КонецЕсли

    
КонецПроцедуры
   jsmith82
 
13 - 01.11.18 - 17:33
(11) 8.3.13, типовой обмен, без разницы
   МаленькийВопросик
 
14 - 01.11.18 - 17:34
(13) а вот мне не помогла регистрация нового коннектора, хотя писалось, что регистрация успешна

пришлось руками добавлять этот коннектор и только тогда взлетело

ошибка есть, подтверждаю

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует