Вход | Регистрация


Как узнать какие права даёт роль?

Как узнать какие права даёт роль?
Я
   Натуральный Йог
 
31.10.18 - 14:01
Как узнать какие права даёт роль?
Открывать роль и протыкивать все объекты метаданных это контрпродуктивно. Где можно увидеть все права, которые дат роль?
 
 
   Fragster
 
1 - 31.10.18 - 14:03
в бас есть отчет
   Fragster
 
2 - 31.10.18 - 14:03
бсп
   Натуральный Йог
 
3 - 31.10.18 - 14:04
(2) как называется?
   Натуральный Йог
 
4 - 31.10.18 - 14:05
Это не тот отчёт, который показывает все роли для объекта? Мне нужно наоборот, все объекты для роли
   daixiao
 
5 - 01.11.18 - 12:33
нет во встроенном языке одного метода, который всё выведет.

Либо открыть роль в конфигураторе и Дествия - Вывести список.

Либо что-то вроде:

р = Метаданные.Роли.ДобавлениеИзменениеСделок;

Сообщить("Справочники:");
Для каждого м из Метаданные.Справочники цикл
    Если ПравоДоступа("Чтение", м, р) Тогда
        Сообщить("        "  + м.Имя);
    КонецЕсли;
КонецЦикла;

Сообщить("Документы:");
Для каждого м из Метаданные.Документы цикл
    Если ПравоДоступа("Чтение", м, р) Тогда
        Сообщить("        "  + м.Имя);
    КонецЕсли;
КонецЦикла;
   AlvlSpb
 
6 - 01.11.18 - 12:53
(0) Возьми вот это http://catalog.mista.ru/public/506884/ Простая но очень классная обработка. Может как показывать объекты по ролям так и роли по объектам, бонус - умеет менять набор ролей пользователю

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует