Вход | Регистрация



мобильное приложение андроид

мобильное приложение андроид
Я
   anatoly
 
31.10.18 - 12:54
пробую первый раз по примеру с диска из книжки.

поставил на смарт мобильную платформу, публикую на апаче конфу из примеров - там получается xml-файлик.

пытаюсь добавить в смартфоне эту конфу с сервера - получаю ошибку разбора xml, в точности как тут: v8: Ошибка разбора XML:Фатальная ошибка: Space required after the Public Identifier

ЧЯДНТ?
может быть причина в том что версия платформы на десктопе (которой публикую) отличается от версии мобильной?
8.3.8.1933 и 8.3.4.22 соответственно.
 
 
   Cyberhawk
 
1 - 31.10.18 - 12:56
Старенькая у тебя мобильная платформа
   anatoly
 
2 - 31.10.18 - 12:57
(1) это с диска который с книжкой:
"знакомство с разработкой мобильных приложений..."
книжка тоже старая))
   Cyberhawk
 
3 - 31.10.18 - 12:58
Меня не особо интересует, откуда оно
   anatoly
 
4 - 31.10.18 - 14:09
не((
попробовал на 2м ноуте (чистом - до этого никакой 1С не было) поставить платформу с того же диска (8.3.4.482) и опубликовать - та же самая ошибка.

в чем подвох??
   Cyberhawk
 
5 - 31.10.18 - 15:00
Старенькая у тебя настольная платформа
   anatoly
 
6 - 31.10.18 - 15:05
(5) это честная учебная.
а так у меня и 8.3.10.2667 есть..
но вопрос то в другом!
   Cyberhawk
 
7 - 31.10.18 - 15:10
Копаться в легаси какой смысл?
   anatoly
 
8 - 31.10.18 - 15:15
(7) знаешь, дружище, извини конечно, а какой смысл в твоих ответах??

ты собирал мобильные приложений? если да - скажи плиз на каких версиях 1С и апача у тебя это получалось? буду признателен.

если нет - какой смысл в твоих ответах?...
   Cyberhawk
 
9 - 31.10.18 - 15:16
Хз о чем ты
   Garikk
 
10 - 31.10.18 - 15:40
(8) вас подводят к тому чтобы вы использовали актуальные версии ПО, а не ковырялись в старье
 
 Рекламное место пустует
   anatoly
 
11 - 31.10.18 - 15:56
(10) может у вас есть опыт сборки мобильных приложения под андроид на "актуальных версиях ПО"? поделитесь?

если нет - я опять же не понимаю какой смысл в таких ответах??

для танкистов: я специально пробовал на тех версиях что были на диске с книжкой.
   Garykom
 
12 - 31.10.18 - 15:58
(0) Смартфон сильно новый? Андроид > 4.4 ?
   Garykom
 
13 - 31.10.18 - 15:58
(12)+ Старые платформы 1С на новых андроидах не але.
   Garikk
 
14 - 31.10.18 - 16:05
(11)
>для танкистов: я специально пробовал на тех версиях что были на диске с книжкой.

использовать надо по возможности актуальные версии ПО, те что на диске - еще не значит что они беспроблемные и рабочие. а у вас так ещё и времен царя гороха. При этом андройд, точнее его SDK активно обновляется
==
Опыт у меня уже устарел на 2 года, но даже так ваши версии  сильно старше
==
>какой смысл в таких ответах??
Смысл натолкнуть на ваш ход мысли в нужном направлении, причем чтобы вы сами дошли до этого направления
Буквально, какой смысл помогать вам устанавливать ПО которые устарело, ваша платформа 8.3.8 вышла в середине 2016 года, по меркам ИТ это прошлый век
   ejikbeznojek
 
15 - 31.10.18 - 16:24
(11) Нужно собрать сборщиком приложение или опубликовать конфу и загрузить её в пустое приложение?
   ejikbeznojek
 
16 - 31.10.18 - 16:29
(11)
Если 2е, то
На компе версия платформы - 8.3 (8.3.9.1850)
На приложении пробовал на всех не тестовых версиях начиная с 8.3.10.51

Меньше всего ошибок в моей конфе было на 8.3.11.57
Версия апача -2.2.22 (Win32)
   ejikbeznojek
 
17 - 31.10.18 - 16:31
(16) Конфа работала начиная с андроида 2.x
Телефон недавно сменил не помню что вместо x
   anatoly
 
18 - 01.11.18 - 08:40
(12) пробовал на HTC Sensation (4.0.3) и Samsung SM-G920f (5.0.2) результат одинаковый.
(15) опубликовать и загрузить. до сборки apk пока рановато. (16) а версия моб.платформы какая?
апач у меня 2.2.31 х64

а можешь выложить или на почту кинуть свой опубликованый xml-файл? его одного же достаточно?

(17) у меня есть 2 старых самсунга - 2.3.5 и 2.3.6 - на них чтоли попробовать??
   Кац
 
19 - 01.11.18 - 08:52
(0) В чем проблема установить актуальную 8.3.12.93 мобильную платформу?

Моя мобильная 8.3.12.67 прекрасно кушает xml публикуемую с платформы 8.3.10.2580
   anatoly
 
20 - 01.11.18 - 09:06
(19) где ее взять? у меня доступа к ИТС сейчас нет..

попробую 8.3.10.84 скачать..
   anatoly
 
21 - 01.11.18 - 09:12
(19) а можешь свою xml выложить или на почту кинуть? пожалуйста)
   Кац
 
22 - 01.11.18 - 09:29
(20) купить доступ, очевидно же 
(21) конечно нет, это коммерческое приложение
   anatoly
 
23 - 01.11.18 - 11:22
(22) а ну тады ой..

(20) на HTC (4.0.3) моб.версия 8.3.10.84 не встала(
на Samsung (5.0.2) встает - но та же ошибка при попытке забрать опубликованую конфу(
   ejikbeznojek
 
24 - 01.11.18 - 12:50
(23) Могу скинуть mxlс копии.
Только у меня твоя почта скрыта.
Ты имеешь ввиду 1cema?
   IVT_2009
 
25 - 01.11.18 - 12:58
Собирал приложение на NEXUS 7 (2012) , там 4.4 версия андроид.
Платформа была 8.3.10 , сама среда от весны 2017 года. Прекратил опыты после того как не смог подружить внешний сканер штрих кода . Мне нужно было программу для сканирования марок написать. Так же эта программа работала на хонор 5с.
   ejikbeznojek
 
26 - 01.11.18 - 13:00
(25) У него я так понял не через сборщик, а через загрузку конфы в пустое приложение, которое идёт в комплекте с платформой)
   anatoly
 
27 - 01.11.18 - 13:20
(24) открыл.
да - я про 1cema.xml

(26) да! до сборки apk я пока не дошел.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует