Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Запись файла в справочник ДО

Запись файла в справочник ДО
Я
   phantom5515
 
31.10.18 - 12:16
Всем привет! Есть обработка, которая по идее должна записывать макет в файлы документооборота. Обработка выполняется, никаких ошибок не выдаёт, но файл не появляется там где должен быть, может быть кто то увидел недостаток в коде.


 Процедура ВыполнитьКоманду(ИмяФайла, ИдентификаторКоманды, Расширение = "xls",Значение = "") Экспорт
     Если ИдентификаторКоманды = "Выгрузка1" Тогда
        Адрес = ВернутьАдрес(Расширение); 
        эл_ = Справочники.Файлы.НайтиПоНаименованию("Контактный справочник");
        если Не ЗначениеЗаполнено(Эл_) тогда
        Эл=Справочники.Файлы.СоздатьЭлемент() ;    
        Эл.ИмяФайла=ИмяФайла;
        Иначе
        Эл=    Эл_.ПолучитьОбъект();
    КонецЕсли;
        Эл.ВладелецФайла = Справочники.ВходящиеДокументы.НайтиПоНаименованию("Контактный справочник");

        Эл.Наименование = "Контактный справочник";
        Эл.ТекстХранилище = ПолучитьИзВременногоХранилища(Адрес);
        
        Эл.Записать();
    //     Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив, СозданныеОбъекты,Расширение = "xls") Экспорт


        //    Данные.Записать(ИмяПромежуточногоФайла);

     КонецЕсли
КонецПроцедуры
        
            // ВС.Записать("D:\Контактный справочник 2018.xls",ТипФайлаТабличногоДокумента.XLS) ;


Функция ВернутьАдрес(Расширение = "xls")
                
             ВС = новый ТабличныйДокумент;
             ВС.Вывод = ИспользованиеВывода.Разрешить;
             ВС =ВернутьТаблДок();
             
        ИмяПромежуточногоФайла = ПолучитьИмяВременногоФайла("xls");
         ВС.Записать(ИмяПромежуточногоФайла,ТипФайлаТабличногоДокумента.XLS) ;
         
         Адрес = ПоместитьВоВременноеХранилище(ИмяПромежуточногоФайла);
        
Возврат Адрес;
КонецФункции
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует