Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

УФ. Пометка на удаление элементов справочника

УФ. Пометка на удаление элементов справочника
Я
   Полька
 
31.10.18 - 10:39
Собственно, пометить нужно весь справочник и не один. Написала. Ничего не происходит. Такое ощущение, что даже выборку не делает, пролетает за долю секунды.

&НаСервере
Процедура ПометитьПодрНаСервере(Команда)
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    СтруктураПредприятия.Ссылка
        |ИЗ
        |    Справочник.СтруктураПредприятия КАК СтруктураПредприятия";
    Выборка = Запрос.Выполнить().Выбрать();
 
    Пока Выборка.Следующий() Цикл
        В=Выборка.Ссылка.ПолучитьОбъект();
        В.УстановитьПометкуУдаления(ИСТИНА);
    КонецЦикла;

КонецПроцедуры
 
 
   Случайный прохожий
 
1 - 31.10.18 - 10:42
В.ПометкаУдаления=Истина;
В.Записать();
   Случайный прохожий
 
2 - 31.10.18 - 10:43
Хотя.. Должно и без этого работать. Уверены, что элементы не помечены на удаление?
   Полька
 
3 - 31.10.18 - 10:46
(2) справочник же виден. не помечены
   Полька
 
4 - 31.10.18 - 10:49
(1) сделала. не помечает.
   Случайный прохожий
 
5 - 31.10.18 - 10:50
Ну тогда старым топоровым методом)) 
Сообщить(В.ПометкаУдаления); перед установкой пометки и после. Что говорит?
   Случайный прохожий
 
6 - 31.10.18 - 10:54
Ну и количество строк в запросе не мешало бы проверить
   Полька
 
7 - 31.10.18 - 10:59
(5) а с сервера "Сообщить" не придет.
   singlych
 
8 - 31.10.18 - 10:59
Обновить список подразделений пробовали?
   Полька
 
9 - 31.10.18 - 11:00
в обычном приложении проверяла- все работает
   Полька
 
10 - 31.10.18 - 11:00
(8) конечно
 
 Рекламное место пустует
   Timon1405
 
11 - 31.10.18 - 11:00
(7) придет
   Случайный прохожий
 
12 - 31.10.18 - 11:01
(7) Что за новость?)) Ну тогда точки останова поставьте
   Полька
 
13 - 31.10.18 - 11:06
(11) (12)  у меня процедура &НаСервере 
не приходит, на "останов" не реагирует
   catena
 
14 - 31.10.18 - 11:07
(13)Выведите в ЖР. Вообще, что ЖР говорит? Происходят действия какие-то?
   Timon1405
 
15 - 31.10.18 - 11:13
(13) мы понимаем что на сервере. после выполнения серверной процедуры массив сообщений с сервера приезжает на клиент и сообщается там.
что отладка не реагирует - см. "включение отладки на сервере", если база клиент-серверная. или проверить, может просто не подключен в отладке сеанс.
   Случайный прохожий
 
16 - 31.10.18 - 11:15
(11) Уверены, что эта процедура вообще запускается?
   1Сергей
 
17 - 31.10.18 - 11:17
(16) +1
   Полька
 
18 - 31.10.18 - 11:21
ЖР говорит, что не запускается
   Случайный прохожий
 
19 - 31.10.18 - 11:22
(18) Кнопочку к процедуре хорошо привязали? :)
   Полька
 
20 - 31.10.18 - 11:24
(19) вроде, хорошо. проверила еще раз.
я первый раз делала обработку на УФ :)))) может, чего пропустила :)))
   Случайный прохожий
 
21 - 31.10.18 - 11:27
(20) ну так с этого и надо было начинать)))

&НаКлиенте
Процедура ПометитьПодр(Команда)
    ПометитьПодрНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПометитьПодрНаСервере()
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    СтруктураПредприятия.Ссылка
        |ИЗ
        |    Справочник.СтруктураПредприятия КАК СтруктураПредприятия";
    Выборка = Запрос.Выполнить().Выбрать();
 
    Пока Выборка.Следующий() Цикл
        В=Выборка.Ссылка.ПолучитьОбъект();
        В.УстановитьПометкуУдаления(ИСТИНА);
    КонецЦикла;
КонецПроцедуры
   Полька
 
22 - 31.10.18 - 11:27
Создала команду. К ней привязала процедуру. Кнопку положила на форму. Что не так?
   Полька
 
23 - 31.10.18 - 11:28
(21) а я сразу ПометитьПодрНаСервере() к кнопке
   palsergeich
 
24 - 31.10.18 - 11:29
(22) Нельзя
   palsergeich
 
25 - 31.10.18 - 11:29
(23) Команда вызвать может только клиентский обработчик
   palsergeich
 
26 - 31.10.18 - 11:30
(21) Вот так и только так
   Случайный прохожий
 
27 - 31.10.18 - 11:30
(22) нужно обработать нажатие на клиенте, а процедуру удаления запускать на сервере. Смотрите (21)
   Timon1405
 
28 - 31.10.18 - 11:30
1) Создаете команду
2) Тащите её мышкой на поле формы.
3) Платформа сама предложит сделать 2 обработчика клиент+сервер
4) Соглашаетесь
   Полька
 
29 - 31.10.18 - 11:34
Спасибо всем :)
Все сработало и сообщения пришли :)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует