Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

ЗУП 3.1 Проблема с правами доступа после обновления.

ЗУП 3.1 Проблема с правами доступа после обновления.
Я
   bvn-2005
 
30.10.18 - 12:39
Проблема возникла после обновления с релиза 3.1.7.144 на 3.1.8.113.
Есть пользователь с ограниченными правами (Табельщик). Он создает документ ПрогулНеявка. Форма нового документа открывается, но ввести в нее ничего нельзя. Права на документ, разумеется, все даны. Если вместо Табельщика поставить права Расчетчика - все начинает работать правильно. В чем может быть проблема?
 
 
   cons24
 
1 - 30.10.18 - 13:33
Конфигуратор открыть и посмотреть ПриСозданииНаСервере() у формы.
   pavlika
 
2 - 30.10.18 - 14:17
Начни с простого - открываешь РС "Права ролей" смотришь какие роли нужны, потом смотришь есть ли они у нужного профиля группы доступа.
   Adilgeriy
 
3 - 30.10.18 - 14:41
обнови базу
   bvn-2005
 
4 - 30.10.18 - 15:55
Дык, это... проблема и возникла после обновления...
Я, конечно, обновил на самый последний релиз (от вчерашнего числа) - не помогло.
"посмотреть ПриСозданииНаСервере() "
Первым делом посмотрел, криминала не увидел. Сравнил с предыдущим "правильным" релизом - изменений нет.
   bvn-2005
 
5 - 30.10.18 - 16:14
" открываешь РС "Права ролей""
Посмотрел. У пользователя доступна роль "Добавление изменение прогулов неявок". Для этой роли в регистре проставил все галки. НЕ помогло.
   DrZombi
 
6 - 31.10.18 - 14:31
(5) Напиши расширение,

Общий модуль "ЗарплатаКадрыРасширенный"

Добавить Роль в расширение "РасшА_ИзменениеДанныхСотрудников", галочки не надо ставить, сама роль галочка.

Копипастишь
      &Вместо("ПраваНаМногофункциональныйДокумент")

Там пишешь код в строке:

    ИзменениеКадровыхДанных = ИзменениеБезОграничений;
    Если Не ИзменениеКадровыхДанных Тогда
        ИзменениеКадровыхДанных = Не ЕстьОграниченияНаУровнеЗаписейПоВидуУчета("Изменение", "КадровыеДанные", ДанныеДляПроверкиОграничений);
        // + .......

        //Эта роль для Табельщика на участках

        Попытка
        Если РольДоступна("РасшА_ИзменениеДанныхСотрудников")
            //Объект.Ссылка        ДокументСсылка.ПрогулНеявка

            И ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.ПрогулНеявка")
            Тогда
            ИзменениеКадровыхДанных = Истина;
        КонецЕсли;
        Исключение
        КонецПопытки;
        // - ...........

    КонецЕсли;
   DrZombi
 
7 - 31.10.18 - 14:34
(4) Криминал в перетасовки кода в "ЕстьОграниченияНаУровнеЗаписейПоВидуУчета()"
   DrZombi
 
8 - 31.10.18 - 14:36
+(6)  //Править функцию... "ПраваНаМногофункциональныйДокумент"

  ЗарплатаКадрыРасширенный.ПраваНаМногофункциональныйДокумент()
   bvn-2005
 
9 - 01.11.18 - 09:02
С доступностью документа разобрался. Просто добавил в ПраваНаМногофункциональныйДокумент():
    Если Пользователи.РолиДоступны("ДобавлениеИзменениеПрогуловНеявок", , Ложь)  тогда         
        Если ТипЗнч(Объект.Ссылка) = Тип("ДокументСсылка.ПрогулНеявка") тогда
            ПраваНаДокумент.ПолныеПраваПоРолям = Истина;
            ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ЧтениеБезОграничений = Истина;
            ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеБезОграничений = Истина;
            ПраваНаДокумент.ОграниченияНаУровнеЗаписей.ИзменениеКадровыхДанных = Истина;
    КонецЕсли;
    КонецЕсли;

Документ открывается, заполняется, сохраняется, но при попытке провести выдает сообщение:
Данные не включены в расчет зарплаты.
и остается непроведенным...
   DrZombi
 
10 - 02.11.18 - 08:20
(9) ...роль не увидел, сенкс...

Зачем так с правами переуседствовал?
Нам хватило только одной строчки "ИзменениеКадровыхДанных = Истина;"
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует