Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УФ. Ошибка передачи данных между клиентом и сервером.

УФ. Ошибка передачи данных между клиентом и сервером.
Я
   Полька
 
30.10.18 - 11:40
Пишу первую обработку на УФ. Вроде, ничего ужасного не делаю. А он так ругается, так ругается :))))

&НаКлиенте
Процедура Загрузить(Команда)
    Выборка = СформироватьВыборкуИЗЗапроса(); 
КонецПроцедуры
    
&НаСервере
Функция  СформироватьВыборкуИЗЗапроса()
    
    Запрос = Новый Запрос;
      Запрос.Текст =    "ВЫБРАТЬ
                      |    Пользователи.*
                      |ИЗ
                      |    Справочник.Пользователи КАК Пользователи";
    ТаблицаДанных = Запрос.Выполнить().Выбрать();
    
    Возврат ТаблицаДанных;
    
КонецФункции


{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(3)}: Ошибка при вызове метода контекста (СформироватьВыборкуИЗЗапроса)
    Выборка = СформироватьВыборкуИЗЗапроса(); 
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
    форма: Элемент
    имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ВыборкаИзРезультатаЗапроса'
 
 
   ejikbeznojek
 
1 - 30.10.18 - 11:59
(0) Может один из реквизитов какой-нибудь подозрительный тип имеет, который нельзя на клиенте.
Выбери только нужные реквизиты и если ошибка останется, удаляй по 1
   Остап Сулейманович
 
2 - 30.10.18 - 12:03
(1) Действительно... Какой же реквизит имеет такой тип, когда написано : Отсутствует отображение для типа 'ВыборкаИзРезультатаЗапроса'?
Интрига...
   Timon1405
 
3 - 30.10.18 - 12:03
(0)на клиенте нельзя ТЗ, используйте
Функция ТаблицаЗначенийВМассив(ТаблицаЗначений) Экспорт
    
    Массив = Новый Массив();
    СтруктураСтрокой = "";
    НужнаЗапятая = Ложь;
    Для Каждого Колонка Из ТаблицаЗначений.Колонки Цикл
        Если НужнаЗапятая Тогда
            СтруктураСтрокой = СтруктураСтрокой + ",";
        КонецЕсли;
        СтруктураСтрокой = СтруктураСтрокой + Колонка.Имя;
        НужнаЗапятая = Истина;
    КонецЦикла;
    Для Каждого Строка Из ТаблицаЗначений Цикл
        НоваяСтрока = Новый Структура(СтруктураСтрокой);
        ЗаполнитьЗначенияСвойств(НоваяСтрока, Строка);
        Массив.Добавить(НоваяСтрока);
    КонецЦикла;
    Возврат Массив;

КонецФункции
   ejikbeznojek
 
4 - 30.10.18 - 12:04
(2) Да, проглядел...сначала прочитал как
ТаблицаДанных = Запрос.Выполнить().Выгрузить();
   Остап Сулейманович
 
5 - 30.10.18 - 12:05
(0) Вот это вот :
ТаблицаДанных = Запрос.Выполнить().Выбрать();
не нужно возвращать на клиента. С ним нужно разбираться не сходя с места (с сервера).
   ejikbeznojek
 
6 - 30.10.18 - 12:06
(3) Можно ((=
https://prnt.sc/lc5bmr
   ejikbeznojek
 
7 - 30.10.18 - 12:06
(6) Но не нужно конечно же)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует