Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УАТ как убрать удаленных водителей

УАТ как убрать удаленных водителей
Я
   galia655z
 
30.10.18 - 07:32
Как в базе 1С Уат переписать механизм подбора по строке для поля Водитель и Транспортное средство документ Путевой лист. После внесения изменений не должны в выбор попадать уволенные сотрудники и выведенные из эксплуатации ТС и не помеченные на удаление
 
 
   Случайный прохожий
 
1 - 30.10.18 - 07:43
В обработке выбора ставь СтандартнаяОбработка = Ложь и пиши туда что хочешь
   galia655z
 
2 - 30.10.18 - 08:44
А как открыть обработку выбора? извиняюсь я не программист
   Генетический мусор
 
3 - 30.10.18 - 09:24
сильно
   ajax_new
 
4 - 30.10.18 - 09:27
(2) Не геодезист случаем?
   galia655z
 
5 - 30.10.18 - 10:01
Нет. Я девочка.
Помогите, плиз... Начальство требует. Так как диспетчера вносят не правильно. А на сопровождение тратиться не хотит.
   2S
 
6 - 30.10.18 - 10:02
(0) убрать все фильтры  в обработчиках
   2S
 
7 - 30.10.18 - 10:02
(5) девочка, тут тебе все скажут, что жопошники идут лесом
   Случайный прохожий
 
8 - 30.10.18 - 10:13
У любого справочника есть модуль менеджера. В нем есть предопределенная процедура ОбработкаПолученияДанныхВыбора. Начинайте копать отсюда
   Krendel
 
9 - 30.10.18 - 10:15
(8) Начать надо с Радченко- знакомство с платформой ;-)
   vova1122
 
10 - 30.10.18 - 10:17
(5) Девочка, А ты в этой компании кто, что начальство требует от тебя? И где программист который обслуживает вашу компанию?
 
 Рекламное место пустует
   galia655z
 
11 - 30.10.18 - 10:30
Это не справочник. Выбирать нужно в Путевом листе Водителя из справочника Сотрудники
   2S
 
12 - 30.10.18 - 10:31
(11) см (6)
   Генетический мусор
 
13 - 30.10.18 - 11:03
Процедура ДиалогВыбораСотрудника(Элемент, ТекСотрудник, ПараметрыОтбора, СтандартнаяОбработка) ЭКСПОРТ
    СтандартнаяОбработка = Ложь;
    ПараметрыФормы = Новый Структура("РежимВыбора, НачальноеЗначениеВыбора", Истина, ТекСотрудник);
    //установим необходимые отборы

    Если ТипЗнч(ПараметрыОтбора) = Тип("Структура") Тогда
        ПараметрыФормы.Вставить("Отбор", ПараметрыОтбора);
    КонецЕсли;
    ОткрытьФорму("Обработка.уатСотрудники.Форма.ФормаСписка", ПараметрыФормы, Элемент);
КонецПроцедуры
 в тут указать
   galia655z
 
14 - 30.10.18 - 13:33
Вот что я ввела в менеджере модуля. А как указать чтоб уволенные сострудники не попадали?
Процедура ОбработкаПолученияДанныхВыбора(ДанныеВыбора, Параметры, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
 ДанныеВыбора = Новый СписокЗначений;
    ДанныеВыбора.Добавить(ПредопределенноеЗначение());
КонецПроцедуры
   galia655z
 
15 - 30.10.18 - 13:37

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует