Вход | Регистрация



Ошибка при открытии релиза 1.3.110.3

Ошибка при открытии релиза 1.3.110.3
Я
   TolstiyBeremenniy
 
30.10.18 - 04:18
Выявлена проблема с обновлением конфигурации УПП 1.3.110.3.
Обновление идет с конфигурации Enterprise_1_3_106_1.
Так как не хватает ресурсов сервере, на релиз 1.3.106.1,
было загруженно обновление Enterprise_1_3_109_1.
Заранее подготовленное.
Потом оно было обновленно на 1.3.110.3.
были произведены все обновления и сохранения на этот релиз.
Но, сейчас при запуске обновленной конфигурации 1.3.110.3
выдается ошибка:

{ОбщийМодуль.ПолныеПрава.Модуль(707)}: Ошибка при получении значения атрибута контекста (ТекущийПользователь)
        Запрос.УстановитьПараметр("ТекущийПользователь", ПараметрыСеанса.ТекущийПользователь);
по причине:
{МодульСеанса(24)}: Слишком много фактических параметров
        Запрос.УстановитьПараметр("ТекущийПользователь", ПараметрыСеанса.ТекущийПользователь);
{ОбщийМодуль.ПолныеПрава.Модуль(707)}: Ошибка при получении значения атрибута контекста (ТекущийПользователь)
        Запрос.УстановитьПараметр("ТекущийПользователь", ПараметрыСеанса.ТекущийПользователь);
по причине:
{МодульСеанса(24)}: Слишком много фактических параметров
        Запрос.УстановитьПараметр("ТекущийПользователь", ПараметрыСеанса.ТекущийПользователь);
{МодульСеанса(24)}: Слишком много фактических параметров
     ИнтеграцияЕГАИС.УстановитьПараметрыСеанса("ИдентификаторСеансаЕГАИС", УстановленныеПараметры);


Что с ней можно сделать?
 
 
   TolstiyBeremenniy
 
1 - 30.10.18 - 04:19
(0+) То есть в самом коде ошибки нет.
Но она выдается.
   TolstiyBeremenniy
 
2 - 30.10.18 - 04:34
Я не знаю что делать. Из за чего идет такая ошибка?
Как её исправлять?
   Пробел
 
3 - 30.10.18 - 04:37
Попробуйте почистить кэш.
   TolstiyBeremenniy
 
4 - 30.10.18 - 04:40
Вот в этой процедуре, не видим ТекущийПользователь
   TolstiyBeremenniy
 
5 - 30.10.18 - 04:58
(3) Я почистил, удалил все каталоги с кракозябрами
из каталогов Local и Roaming.

Что то ещё нужно сделать?
   Случайный прохожий
 
6 - 30.10.18 - 05:10
Конфигуратор не предлагать? :)
   TolstiyBeremenniy
 
7 - 30.10.18 - 05:14
(6) там не срабатывает точка останова!
Сразу из конфигуратора запускается предприятие
и выходит ошибка!!!!!
   TolstiyBeremenniy
 
8 - 30.10.18 - 05:15
Сейчас вот такая ошибка стала выходить, - 



{МодульСеанса(24)}: Слишком много фактических параметров
     ИнтеграцияЕГАИС.УстановитьПараметрыСеанса("ИдентификаторСеансаЕГАИС", УстановленныеПараметры);
{МодульСеанса(24)}: Слишком много фактических параметров
     ИнтеграцияЕГАИС.УстановитьПараметрыСеанса("ИдентификаторСеансаЕГАИС", УстановленныеПараметры);



на процедуру.


Процедура УстановкаПараметровСеанса(ТребуемыеПараметры)
    
    Если ТребуемыеПараметры = Неопределено Тогда
        // раздел "безусловной" инициализации параметров сеанса

        
        ПолныеПрава.УстановитьПараметрыМеханизмаОграниченияПравДоступа();
        
    Иначе        
        
        УстановленныеПараметры = Новый Структура;
        
        Для Каждого ИмяПараметра ИЗ ТребуемыеПараметры Цикл
            УстановитьЗначениеПараметраСеанса(ИмяПараметра, УстановленныеПараметры);
        КонецЦикла;
        
    КонецЕсли;
    
    // СтандартныеПодсистемы

    СтандартныеПодсистемыСервер.УстановкаПараметровСеанса(ТребуемыеПараметры);
    // Конец СтандартныеПодсистемы

    
    // ЕГАИС 

     ИнтеграцияЕГАИС.УстановитьПараметрыСеанса("ИдентификаторСеансаЕГАИС", УстановленныеПараметры);
    // Конец ЕГАИС

    
    ПараметрыСеанса.УдаляемыйДокумент = Неопределено;
    
КонецПроцедуры
   TolstiyBeremenniy
 
9 - 30.10.18 - 05:16
Что запускается в самом начале при старте УПП.
Почему не останавливается на точке останова?
   Пробел
 
10 - 30.10.18 - 05:22
похоже кривое обновление. В 1.3.106 ИнтеграцияЕГАИС.УстановитьПараметрыСеанса выглядит так:


// Выполняет установку параметров сеанса. Вызывается из модуля сеанса.

//
Процедура УстановитьПараметрыСеанса(ТребуемыеПараметры) Экспорт
    
    Если ТипЗнч(ТребуемыеПараметры) <> Тип("Массив") Тогда
        Возврат;
    КонецЕсли;
    
    Для Каждого ИмяПараметра Из ТребуемыеПараметры Цикл
        Если ИмяПараметра = "ИдентификаторСеансаЕГАИС" Тогда
            ПараметрыСеанса.ИдентификаторСеансаЕГАИС = Новый УникальныйИдентификатор;
        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры


Попробуйте заменить эту процедуру процедурой из конфигурации поставщика.

А отладка у Вас, возможно, не работает из-за того, что в командной строке агента сервера не указан debug
 
 Рекламное место пустует
   TolstiyBeremenniy
 
11 - 30.10.18 - 05:23
(10) обычное приложение. Там тоже нужен debug?
   Михаил Иванович
 
12 - 30.10.18 - 05:33
Похоже ТС это ливингстар.
   Пробел
 
13 - 30.10.18 - 05:35
(11) а, ну да. Должно отлаживаться без дебага.
   Пробел
 
14 - 30.10.18 - 05:39
Я бы поднял бэкап и повторил цепочку обновлений, аккуратно и вдумчиво. Если ошибка вылезла при старте системы, то другие ошибки могут вылезти вообще где угодно.
   TolstiyBeremenniy
 
15 - 30.10.18 - 05:41
(14) Проблема в том что это не реально.
Сервер не дает ресурсы.
   TolstiyBeremenniy
 
16 - 30.10.18 - 05:46
(14)

Так а если релизы

Enterprise_1_3_106_1
Enterprise_1_3_107_1
Enterprise_1_3_108_2
Enterprise_1_3_109_1

все запустились?

а Enterprise_1_3_110_3 нет. почему проблема в релизе 1_3_106_1 ?
   НоваяВолна
 
17 - 30.10.18 - 05:48
(16) да пересоздай ты уже пользователя и не парься...
   Пробел
 
18 - 30.10.18 - 05:49
(16) тогда возьмите 109 и обновите на 110. При сравнении-объединении обратите особое внимание на общий модуль "ИнтеграцияЕГАИС".
   TolstiyBeremenniy
 
19 - 30.10.18 - 05:52
(18) Я пока делал через поддержка. Обновить конфигурацию.
   НоваяВолна
 
20 - 30.10.18 - 05:52
(19) упссс ... это интересно. Неужели?
   TolstiyBeremenniy
 
21 - 30.10.18 - 05:57
(20) Да, а почему интересно?
Автоматическое обновление типовых релизов.
   TolstiyBeremenniy
 
22 - 30.10.18 - 06:09
(18) Да тут не в этом дело.
Обновление прошло. И я сверил процедуры.
В типовом 1.3.106.1 и 1.3.110.3, они идентичны.

Дело в том что Ругается на текущего пользователя.

он же всегда должен быть в параметрах сеанса!

а если обычное приложение, почему не работает отладка?
   Mankubus
 
23 - 30.10.18 - 06:13
(1) как это  в коде нет ошибки? В процедуре может быть только 1 параметр, а в неё передаётся 2 параметра
   TolstiyBeremenniy
 
24 - 30.10.18 - 06:14
Или все же нужен debug на сервере?
Открыл файловую версию, там запускается отладка. А тут нет.
   TolstiyBeremenniy
 
25 - 30.10.18 - 06:16
Подскажите как именно включить debug ?
   НоваяВолна
 
26 - 30.10.18 - 06:30
   TolstiyBeremenniy
 
27 - 30.10.18 - 07:43
А почему могло быть что Enterprise_1_3_109_1 релиз
запустился.
А на 1.3.110.3. стали выходить ошибки?
Пока на сервере не запустить отладку.
Я выгрузил .cf в файловую базу и там тоже есть в журнале ошибки.

Просматривал их через журнал регистрации, -

{ОбщийМодуль.ОбменДаннымиВызовСервера.Модуль(88)}: Ошибка при получении значения атрибута контекста (ДатаОбновленияПовторноИспользуемыхЗначенийМРО)
        Если ПараметрыСеанса.ДатаОбновленияПовторноИспользуемыхЗначенийМРО <> АктуальнаяДата Тогда
по причине:
{МодульСеанса(24)}: Слишком много фактических параметров
        Если ПараметрыСеанса.ДатаОбновленияПовторноИспользуемыхЗначенийМРО <> АктуальнаяДата Тогда

{ОбщийМодуль.ПолныеПрава.Модуль(641)}: Ошибка при получении значения атрибута контекста (ТекущийПользователь)

{ОбщийМодуль.ОбменДаннымиВызовСервера.Модуль(88)}: Ошибка при получении значения атрибута контекста (ДатаОбновленияПовторноИспользуемыхЗначенийМРО)
        Если ПараметрыСеанса.ДатаОбновленияПовторноИспользуемыхЗначенийМРО <> АктуальнаяДата Тогда
по причине:
{МодульСеанса(24)}: Слишком много фактических параметров
        Если ПараметрыСеанса.ДатаОбновленияПовторноИспользуемыхЗначенийМРО <> АктуальнаяДата Тогда

{ОбщийМодуль.ПолныеПрава.Модуль(641)}: Ошибка при получении значения атрибута контекста (ТекущийПользователь)

{МодульСеанса(24)}: Слишком много фактических параметров

Обновление информационной базы на версию "1.3.110.3" завершилось с ошибками: 
{(1)}: Метод объекта не обнаружен (ЗаполнитьВходящиеДокументыНастроек)
Справочники.СоглашенияОбИспользованииЭД.ЗаполнитьВходящиеДокументыНастроек()
   Lexey_
 
28 - 30.10.18 - 07:45
(12) да, это ливингстар


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует