Вход | Регистрация


Обработка выбораю УФ.

Обработка выбораю УФ.
Я
   Генетический мусор
 
29.10.18 - 14:39
Реквизит на форме строка.

Обработчик начало выбора
&НаКлиенте
Процедура АдресПолучателяФактическийНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка = Ложь;
    
    СтруктураПараметров = Новый Структура;
    СтруктураПараметров.Вставить("Отбор", Новый Структура("Объект, Тип, Вид", Объект.Контрагент, ПолучитьТипыКонтактнойИнформацииАдрес(), ПолучитьВидыКонтактнойИнформации()));
    ОткрытьФорму("Справочник.КонтактнаяИнформация.ФормаВыбора", 
        СтруктураПараметров, ЭтаФорма, УникальныйИдентификатор,,,);
КонецПроцедуры


По нему провалился куда нужно, нажимаю выбор в форме списка в - 

&НаКлиенте
Процедура АдресПолучателяФактическийОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    //Вставить содержимое обработчика.

    СтандартнаяОбработка = Ложь;
    
    Если ТипЗнч(ВыбранноеЗначение) = Тип("СправочникСсылка.КонтактнаяИнформация") Тогда
        Объект.АдресПолучателяРегистрации = ВыбранноеЗначение.Представление;
        АдресПолучателяРегистрации = ВыбранноеЗначение.Представление;
        Объект.АдресДоставки = ВыбранноеЗначение.Представление;
    КонецЕсли;
    УстановитьПредставлениеАдресов();
    ЭтаФорма.Модифицированность = Истина;

КонецПроцедуры

ВыбранноеЗначение = <>  и хоть тресни, заклинило, помогите, спасибо
 
 
   Cyberhawk
 
1 - 29.10.18 - 14:52
Много букв. Давай видосик.
   D3O
 
2 - 29.10.18 - 14:57
(0) ОткрытьФорму("Справочник.КонтактнаяИнформация.ФормаВыбора",
        СтруктураПараметров, ЭтаФорма, УникальныйИдентификатор,,,);

тут ошибка. владелец должен быть тот элемент, куда должно все вернуться. так возвращается на саму форму.
   Генетический мусор
 
3 - 29.10.18 - 17:58
(2) ПараметрыОтбора = Новый Структура("Объект, Тип, Вид", Объект.Контрагент, ПолучитьТипыКонтактнойИнформацииАдрес(), ПолучитьВидыКонтактнойИнформации());
    ОткрытьФорму("Справочник.КонтактнаяИнформация.ФормаВыбора", ПараметрыОтбора, Элемент);

тоже самое(, где то рядом, где - потерял)
   Генетический мусор
 
4 - 30.10.18 - 06:11
сам дурак

в справочник Контактные лица добавил

&НаКлиенте
Процедура ПриЗакрытии(ЗавершениеРаботы)
        Если НЕ Элементы.Список.ТекущиеДанные = НЕОПРЕДЕЛЕНО и Элементы.Список.ВыделенныеСтроки.Количество() = 1 Тогда
            СтруктураРезультат = Новый Структура("Объект, Тип, Вид, Представление");
            СтруктураРезультат.Вставить("Объект", Элементы.Список.ТекущиеДанные.Объект);
            СтруктураРезультат.Вставить("Тип", Элементы.Список.ТекущиеДанные.Тип);
            СтруктураРезультат.Вставить("Вид", Элементы.Список.ТекущиеДанные.Вид);
            СтруктураРезультат.Вставить("Представление", Элементы.Список.ТекущиеДанные.Представление);
            ОповеститьОВыборе(СтруктураРезультат);
        Иначе
            СтруктураРезультат = Новый Структура("Объект, Тип, Вид, Представление");
            СтруктураРезультат.Вставить("Объект", НЕОПРЕДЕЛЕНО);
            СтруктураРезультат.Вставить("Тип", НЕОПРЕДЕЛЕНО);
            СтруктураРезультат.Вставить("Вид", НЕОПРЕДЕЛЕНО);
            СтруктураРезультат.Вставить("Представление", НЕОПРЕДЕЛЕНО);
            ОповеститьОВыборе(СтруктураРезультат);
        КонецЕсли;

КонецПроцедуры

привязал к форме, заработало, спс

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует