Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Скроем колонку табличной части 8.3

Скроем колонку табличной части 8.3
Я
   МаленькийВопросик
 
29.10.18 - 12:52
Подскажите как исправить данную процеду - ругается на имя колонки. Спасибо!

&НаКлиенте
Процедура СкроемПустыеКолонки()

    Колонки     = Объект.ИтоговаяТаблица.Колонки;
    
    Отображать41Дт = 0;
    
    Для Каждого Стр11 ИЗ Объект.ИтоговаяТаблица Цикл
        Отображать41Дт = Отображать41Дт + Стр11.Дт41;
    КонецЦикла;    
    
    Если Отображать41Дт = 0 Тогда
        
        ЭтаФорма.Элементы["ИтоговаяТаблицаДт41"].Видимость = Ложь;
        
    КонецЕсли;    
    
    
    
КонецПроцедуры
 
 
   МаленькийВопросик
 
1 - 29.10.18 - 13:17
Апнем тему, спасиьо!
   asady
 
2 - 29.10.18 - 13:25
(0) посмотри к конфигураторе имя поля "Дт41"  на форме - как точно оно там называется.
   elCust
 
3 - 29.10.18 - 13:27
>> ЭтаФорма.Элементы["ИтоговаяТаблицаДт41"].Видимость = Ложь;

На эту строку ругается?
   asady
 
4 - 29.10.18 - 14:58
(3) это понятно.
открой глаза и глянь в конфигуратор ответь на (2)
   МаленькийВопросик
 
5 - 29.10.18 - 15:32
(4) ИтоговаяТаблицаДт41
   ЦиркУехал
 
6 - 29.10.18 - 15:38
(5) к ней Можно еще и по номеру обращаться.
яб попробовал.
   МаленькийВопросик
 
7 - 29.10.18 - 15:40
ЭтаФорма.Элементы.ИтоговаяТаблицаДт41.Видимость = Ложь;
   МаленькийВопросик
 
8 - 29.10.18 - 15:40
Всем спасибо!
   Вафель
 
9 - 29.10.18 - 15:41
ЭтаФорма.Элементы.ИтоговаяТаблицаДт41.Видимость = Ложь;

и
ЭтаФорма.Элементы["ИтоговаяТаблицаДт41"].Видимость = Ложь;

эквивалентны
   Cyberhawk
 
10 - 29.10.18 - 15:55
(9) Первое устойчивее к переименованиям и автозамене, т.к. второе тупо вообще не участвует в этом процессе. Но второе выглядит как-то красивее.
 
 Рекламное место пустует
   МаленькийВопросик
 
11 - 29.10.18 - 16:05
(10) мудренее )
   Cyberhawk
 
12 - 29.10.18 - 16:13
Самое западло, это то что сделали функцию ПредопределенноеЗначение (дает доступ с клиента + кеширование), но в автозамене при переименовании оно не работает
   Cyberhawk
 
13 - 29.10.18 - 16:14
(11) Зато через квадратные скобки сразу дает понимание, что вместо строки можно и строковую переменную там использовать. В отличе от через точку.
   МаленькийВопросик
 
14 - 29.10.18 - 18:25
(13) понимание, что там вообще можно переменную использовать, да это так...

а что там с автозаменой?
   Cyberhawk
 
15 - 29.10.18 - 18:31

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует