Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Обращение к общему модулю из ПриНачалеРаботыСистемы()

Обращение к общему модулю из ПриНачалеРаботыСистемы()
Я
   IgoryanYa
 
29.10.18 - 12:42
Всем привет. Уважаемые люди подскажите пожалуйста. Имею 1с Розницу 8.3. Задача простейшая. При входе в программу необходимо вывести сообщение о днях рождения клиентов. Я знаю что у модуля управляемого приложения есть процедура "ПриНачалеРаботыСистемы()" Понятно что если в конце процедуры прописать Сообщить("Например сегодня ДР у чувака") то при открытие программы я получу сообщение. Но что бы получить данные из базы я создал общий модуль "СообщитьОДняхРожденияКлиентов" и прописал там код

&НаКлиенте
Процедура СообщитьОДняхРожденияКлиентов()
Массив = СообщитьОДняхРожденияКлиентовНаСервере();
Для Каждого Строка из Массив Цикл
    ПоказатьПредупреждение(,Строка);
КонецЦикла;    
КонецПроцедуры

&НаСервере
Функция СообщитьОДняхРожденияКлиентовНаСервере()
Выборка = Справочники.Клиенты.Выбрать();
Массив = Новый Массив;
    Пока Выборка.Следующий() Цикл
        Если 
            Лев(Строка(Формат(Выборка.ДатаРождения,"ДЛФ=D")),5) = Лев(Строка(Формат(ТекущаяДата(),"ДЛФ=D")),5)
        Тогда
            Строка = ("Внимание!!! " + Выборка.Наименование + " праздрунет сегодня День Рождения !!!. Надо клиенту позвонить и поздравить !!!!!"); 
            Массив.Добавить(Строка);
            Сообщить(Строка);
        КонецЕсли;
    КонецЦикла;    
Возврат Массив;
КонецФункции

Если например через внешнюю обработку запускать то все норм (ПоказатьПредупреждение использовал так для себя, знаю что можно Сообщить() с сервера), но вот как запустить мой модуль или процедуру из под процедуры ПриНачалеРаботыСистемы()???

Или может есть какой нибудь другой вариант?
 
 
   Ёпрст
 
1 - 29.10.18 - 12:44
>>>
Лев(Строка(Формат(Выборка.ДатаРождения,"ДЛФ=D")),5) = Лев(Строка(Формат(ТекущаяДата(),"ДЛФ=D")),5)

Это пять!
   Lexey_
 
2 - 29.10.18 - 12:45
"праздрунет"
"Надо клиенту позвонить и поздравить !!!!!"
   manc88
 
3 - 29.10.18 - 13:03
(1)
   IgoryanYa
 
4 - 29.10.18 - 13:15
(1) Ахаха ну ничего в голову не пришло другого, если знаете как лучше, поделитесь.
   IgoryanYa
 
5 - 29.10.18 - 13:16
(2) так читабельней
   Fragster
 
6 - 29.10.18 - 13:21
нужно создать напоминания для пользователя в регламентном задании. нужно создать отчет и поместить его на рабочий стол (менее предпочтительно) или открывать этот отчет при старте.


ну и (1) прав, да
   Fragster
 
7 - 29.10.18 - 13:22
нужно = можно
   Exxter
 
8 - 29.10.18 - 13:29
Общую форму на рабочий стол, поздравили скрыл.
   bolobol
 
9 - 29.10.18 - 13:45
(8) Да, кстати, что будет если скрыл, что поздравил?
   Сияющий в темноте
 
10 - 29.10.18 - 13:52
Какие сообщения,открой форму,если поздравлять некого,то при открытии формы заруби открытие,если есть,то в таблицу на форме,и чтобв крыжили,кого поздравили,ведь розницу несколько раз могут запустить,а могут и с вечера не открыть.
 
 Рекламное место пустует
   Сияющий в темноте
 
11 - 29.10.18 - 13:53
не закрыть...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует