Вход | Регистрация


внешняя обработка заполнения табличной части документа, разместить в другом месте формы

внешняя обработка заполнения табличной части документа, разместить в другом месте формы
Я
   inkvizitr
 
29.10.18 - 10:29
создал внешнею обработку по заполнении ТЧ документа, она располагается в вверху формы, можно ли ее включить в командную панель самой табличной части, и если можно то как? я так  понимаю это в делается в СведенияОВнешнейОбработке() но не знаю как.
Вот как подключаю внешнею обработку к базе
Функция СведенияОВнешнейОбработке() Экспорт
    Назначения = Новый Массив ;
    Назначения.Добавить("Документ.АвизоОСИсходящее") ;
    
    ПараметрыРегистрации = Новый Структура ;
    ПараметрыРегистрации.Вставить("Вид","ЗаполнениеОбъекта");
    ПараметрыРегистрации.Вставить("Назначение",Назначения);
    ПараметрыРегистрации.Вставить("Наименование","Обработка по заполнения ТЧ документа авизо ОС исходящие");
    ПараметрыРегистрации.Вставить("Версия","1.0");
    ПараметрыРегистрации.Вставить("Информация","Обработка по заполнения ТЧ документа авизо ОС исходящие");
    ПараметрыРегистрации.Вставить("БезопасныйРежим",Истина);
    
    Команды = ПолучитьТаблицуКоманд() ;
    ДобавитьКоманду(Команды, "Заполнить ОС","ЗаполнитьОС","ВызовКлиентскогоМетода",Ложь,) ;
    
    ПараметрыРегистрации.Вставить("Команды",Команды) ;
    
    Возврат ПараметрыРегистрации;
    
КонецФункции

    Функция ПолучитьТаблицуКоманд()
        Команды = Новый ТаблицаЗначений ;
        Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка")) ;
        Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")) ;
        Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")) ;
        Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево")) ;
        Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка")) ;
        Возврат Команды ;
    КонецФункции    

    Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
        НоваяКоманда = ТаблицаКоманд.Добавить() ;
        НоваяКоманда.Представление = Представление ;
        НоваяКоманда.Идентификатор = Идентификатор ;
        НоваяКоманда.Использование = Использование ;
        НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение ;
        НоваяКоманда.Модификатор = Модификатор ;
    КонецПроцедуры
 
 
   Вафель
 
1 - 29.10.18 - 10:32
только в пользовательском режиме через изменить форму
   inkvizitr
 
2 - 29.10.18 - 10:36
(1) да спасибо работает, а программно вообще получается ни как?
   inkvizitr
 
3 - 29.10.18 - 11:20
а еще момент не подскажите, обработка при попытке заполнить ТЧ, предлагает документ записать, а можно предварительную запись как то не выполнять
   OldCondom
 
4 - 29.10.18 - 11:26
Конечно можно
   inkvizitr
 
5 - 29.10.18 - 11:37
(4) а как это реализовать, хотя бы простой пример
   inkvizitr
 
6 - 29.10.18 - 11:38
или при вызеве команды, что прописать, чтобы та не сохранялась

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует