Вход | Регистрация


Не могу заполнить ТЧ

Не могу заполнить ТЧ
Я
   inkvizitr
 
27.10.18 - 19:04
заполняю внешней обработкой ТЧ документа авизо ос исходящий, цикл отрабатывает как надо, но данные на форме не появляются, что забыл сделать, чтобы отобразить данные на форме документа

&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения) Экспорт
    ЭтаФорма.Открыть();
    ЭтаФорма.АвтоЗаголовок=Ложь;
    ЭтаФорма.Заголовок="Выбери организацию";
КонецПроцедуры


&НаКлиенте
Процедура ЗаполнитьДокумент(Команда, ОбъектыНазначенияМассив)
    ВладелецФормы=ЭтаФорма.ВладелецФормы;
    Если Найти(ВладелецФормы.ИмяФормы,"ФормаДокумента")>0 Тогда        
        ВладелецОбъект=ВладелецФормы.Объект;
    КонецЕсли;
    ВыполнитьНаСервере(ВладелецОбъект);
КонецПроцедуры

&НаСервере
Процедура ВыполнитьНаСервере(ОбъектОбъекта)
    Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    МестонахождениеОСБухгалтерскийУчетСрезПоследних.НомерСтроки КАК НомерСтроки,
    |    МестонахождениеОСБухгалтерскийУчетСрезПоследних.ОсновноеСредство КАК ОсновноеСредство
    |ИЗ
    |    РегистрСведений.МестонахождениеОСБухгалтерскийУчет.СрезПоследних(, Организация = &Орг) КАК МестонахождениеОСБухгалтерскийУчетСрезПоследних";
    
    Запрос.УстановитьПараметр("орг", Организация);
    Результат = Запрос.Выполнить();
    Выгрузка = Результат.Выгрузить();
    
    Результат = Документы.АвизоОСИсходящее.ПолучитьДанныеОС(ОбъектОбъекта, Выгрузка);
    ВыборкаОС = Результат.Выгрузить();
    
    ОбъектОбъекта.ОС.Очистить();        
    
    Для Каждого СтрокаОС ИЗ ВыборкаОС Цикл
        СтрокаТЧ = ОбъектОбъекта.ОС.Добавить();
        СтрокаТЧ.ОсновноеСредство = СтрокаОС.ОсновноеСредство;
    КонецЦикла;
КонецПроцедуры
 
 
   lodger
 
1 - 27.10.18 - 20:14
   inkvizitr
 
2 - 28.10.18 - 23:38
там указанно в примере, чтобы форма обработки не отображалась. а у меня выводиться форма, где пользователь выбирает организацию, жмет кнопку и по задумке должна заполниться ТЧ формы документа, где вызывается данная обработка
   МимохожийОднако
 
3 - 29.10.18 - 06:32
(2) Используй режим с открытием формы обработки или формы диалога выбора организации. Хотя не понятно, зачем эту организацию выбирать.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует