Вход | Регистрация


Не открывается внешняя обработка

Не открывается внешняя обработка
Я
   inkvizitr
 
26.10.18 - 16:31
Не открывается внешняя обработка ошибка (ВыполнитьКоманду)
        ФормаОбработки.ВыполнитьКоманду(ВыполняемаяКоманда.Идентификатор, ОбъектыНазначения); как его задать? чего то весь инет перекопал.

Обработка подключается к базе, отображается в форме документа, при попытке нажать, выходит сообщение выше
 
 
   inkvizitr
 
1 - 26.10.18 - 16:32
Функция СведенияОВнешнейОбработке() Экспорт
    Назначения = Новый Массив ;
    Назначения.Добавить("Документ._ДемоЗаказПокупателя") ;
    
    ПараметрыРегистрации = Новый Структура ;
    ПараметрыРегистрации.Вставить("Вид","ЗаполнениеОбъекта");
    ПараметрыРегистрации.Вставить("Назначение",Назначения);
    ПараметрыРегистрации.Вставить("Наименование","Заполнить Документ");
    ПараметрыРегистрации.Вставить("Версия","1.0");
    ПараметрыРегистрации.Вставить("Информация","Дополнительная обработка табличной части требования");
    ПараметрыРегистрации.Вставить("БезопасныйРежим",Истина);
    
    Команды = ПолучитьТаблицуКоманд() ;
    ДобавитьКоманду(Команды, "Заполнить документ","ЗаполнитьДокумент","ВызовКлиентскогоМетода",Ложь,) ;
    
    ПараметрыРегистрации.Вставить("Команды",Команды) ;
    
    Возврат ПараметрыРегистрации;
    
КонецФункции

    Функция ПолучитьТаблицуКоманд()
        Команды = Новый ТаблицаЗначений ;
        Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка")) ;
        Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")) ;
        Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")) ;
        Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево")) ;
        Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка")) ;
        Возврат Команды ;
    КонецФункции    

    Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
        НоваяКоманда = ТаблицаКоманд.Добавить() ;
        НоваяКоманда.Представление = Представление ;
        НоваяКоманда.Идентификатор = Идентификатор ;
        НоваяКоманда.Использование = Использование ;
        НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение ;
        НоваяКоманда.Модификатор = Модификатор ;
    КонецПроцедуры
   inkvizitr
 
2 - 26.10.18 - 16:33
ошибка полностью 

{ОбщийМодуль.ДополнительныеОтчетыИОбработкиКлиент.Модуль(480)}: Метод объекта не обнаружен (ВыполнитьКоманду)
        ФормаОбработки.ВыполнитьКоманду(ВыполняемаяКоманда.Идентификатор, ОбъектыНазначения);

Смотрел отладчиком на строке 480 не пойму чего не хватает
   Lexey_
 
3 - 26.10.18 - 16:35
(2)"не пойму чего не хватает"
ну вот же: Метод объекта не обнаружен (ВыполнитьКоманду)
   inkvizitr
 
4 - 26.10.18 - 16:40
(3) все, разобрался, надо было в форму обработки добавить

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует