Вход | Регистрация


Ограничить размер помещаемого файла. Как?

Ограничить размер помещаемого файла. Как?
Я
   bolobol
 
26.10.18 - 10:28
День добрый!

Подскажите, пожалуйста, как можно реализовать следующее:
- поместить файл конкретного расширения - пидиэф, размера не более 1,5 ме6габайт.

НачатьПомещениеФайла предполагает, что только настройки диалога открытия файла передаются, где можно в качестве рекомендации передать тип - пидиэф. А в диалоге - звёздочкой воспользоваться - никто не отменял. Ответ помещения файла - временное хранилище, которое тоже можно только получить.

Как тогда именно ограничить тип помещаемого файла и его размер?

Спасибо!
 
 
   ZDenis
 
1 - 26.10.18 - 10:32
(0) Посмотри как реализовано в типовых
   ZDenis
 
2 - 26.10.18 - 10:34
аа не внимателен, тип плюс размер нужен.
   ZDenis
 
3 - 26.10.18 - 10:47
(0) Хотя вот код из типовой, там и размер и тип известен

// Вызывает исключение, если файл имеет недопустимый размер для загрузки.

Процедура ПроверитьРазмерФайлаДляЗагрузки(Файл) Экспорт
    
    ОбщиеНастройки = ОбщиеНастройкиРаботыСФайлами();
    
    Если ТипЗнч(Файл) = Тип("Файл") Тогда
        Размер = Файл.Размер();
    Иначе
        Размер = Файл.Размер;
    КонецЕсли;
    
    Если Размер > ОбщиеНастройки.МаксимальныйРазмерФайла Тогда
    
        РазмерВМб     = Размер / (1024 * 1024);
        РазмерВМбМакс = ОбщиеНастройки.МаксимальныйРазмерФайла / (1024 * 1024);
        
        Если ТипЗнч(Файл) = Тип("Файл") Тогда
            Имя = Файл.Имя;
        Иначе
            Имя = ОбщегоНазначенияКлиентСервер.ПолучитьИмяСРасширением(
                Файл.ПолноеНаименование, Файл.Расширение);
        КонецЕсли;
        
        ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru = 'Размер файла ""%1"" (%2 Мб)
                       |превышает максимально допустимый размер файла (%3 Мб).'"),
            Имя,
            ПолучитьСтрокуСРазмеромФайла(РазмерВМб),
            ПолучитьСтрокуСРазмеромФайла(РазмерВМбМакс));
    КонецЕсли;
    
КонецПроцедуры
   bolobol
 
4 - 26.10.18 - 10:50
Так вот и непонятно, как файл получить ДО помещения?
Отдельно от помещения диалог выбора файла вызывать и проверять его параметры, затем уже на сервер отправлять?
Только так?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует