Вход | Регистрация


Подскажите по программному подключению сканера в УФ

Подскажите по программному подключению сканера в УФ
Я
   VKS
 
25.10.18 - 09:31
Добрый день

В типовых на толстом клиенте была такая конструкция (на примере УТ10.3):
Если нужно было в новом документе подключить сканер штрихкода, то добавляли
1. в процедуру ПриОткрытии процедуру подключения торгового оборудования ПолучитьСерверТО().ПодключитьКлиента(ЭтаФорма);

Основном модуль был в обработки ТОСервере

2. В документ так же добавляли функцию ПоддерживаетсяВидТО(Вид) Экспорт

3. Процедура ВнешнееСобытие(Источник, Событие, Данные)
перехватывала считывание штрихкода, которое в дальнейшем обрабатывалось и возвращалось в процедуру СШКНоменклатура(Номенклатура, Характеристика, Серия, Качество,
                        Единица, Количество, СШК) Экспорт
и как-то там обрабатывалась

4. При закрытии формы торговое оборудование отключалось.


Подскажите, как это на управляемых формах реализовано в типовых? Идеально будет на примере УТ 11.4
 
 
   VKS
 
1 - 25.10.18 - 09:35
Вижу что так же при открытии и закрытии подключается торговое оборудование. А как событие считывание обрабатывается? Смотрю нет внешнего события формы, как на толстом клиенте
   asady
 
2 - 25.10.18 - 09:43
(0) в УФ ещё проще.
Администрирвоание- подключаемое оборудование 
там настрой рабочее место - сканер шк

а в своей форме ОбработкаОповещения

Например:

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    // ПодключаемоеОборудование

    Если Источник = "ПодключаемоеОборудование" И ВводДоступен() Тогда
        Если ИмяСобытия = "ScanData" И МенеджерОборудованияКлиентПереопределяемый.ЕстьНеобработанноеСобытие() Тогда
            ОбработатьШтрихкоды(тзПрочееКлиент.ПреобразоватьДанныеСоСканераВСтруктуру(Параметр));
        КонецЕсли;
    КонецЕсли;
    // Конец ПодключаемоеОборудование

КонецПроцедуры

#КонецОбласти

#Область ШтрихкодыИТорговоеОборудование


&НаКлиенте
Процедура ОбработатьШтрихкоды(Данные)
    
    тУИД = ПолучитьУИДпоШтрихкоду(Данные.Штрихкод);
    тСобытие = тзПроизводствоКлиент.СоздатьСобытиеПоУИД(тУИД);
    Элементы.ЖурналСобытий.Обновить();    
КонецПроцедуры
   depi
 
3 - 25.10.18 - 09:43
Розница, редакция 2.2 (2.2.9.20)

&НаКлиенте
Процедура ОповещениеПоискаПоШтрихкоду(Штрихкод, ДополнительныеПараметры) Экспорт
    
    Если НЕ ПустаяСтрока(Штрихкод) Тогда
        СтруктураПараметровКлиента = ПолученШтрихкодИзСШК(Штрихкод);
        ОбработатьДанныеПоКодуКлиент(СтруктураПараметровКлиента);
    КонецЕсли;
    
КонецПроцедуры
   VKS
 
4 - 25.10.18 - 09:54
(2) (3) спасибо ребята

да, оказывается даже проще стало. Событие обрабатывается через, на примере УТ11.4 МодульУправляемогоПриложения.ОбработкаВнешнегоСобтия (....)
и передается в ОбработкуОповещения формы

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует