Вход | Регистрация



XDTO - как обычно туплю

XDTO - как обычно туплю
Я
   Cool_Profi
 
24.10.18 - 12:28
Есть вот такой объект XDTO (не список)
    л_Изменения = ФабрикаXDTO.ПрочитатьXML(л_ЧтениеXML);
    
Тут получаем конкретный элемент объекта
    л_ПКО = л_Данные.ПравилаКонвертацииОбъектов;
    
И тут другой.
    л_Группа = л_ПКО.Группа;

Добавляем новую группу
    л_ПравилоГрп = л_Группа.Добавить(XDTOНовый());
    
А теперь хотим в Группа добавить элемент <Правила>

    л_Правило = л_ПравилоГрп.Добавить("Правило", XDTOНовый());

И ничего не получается...

Имеем в результате запись
<Группа>
//тут элементы правила

</Группа>

А надо бы группа - правило
 
 
   Cyberhawk
 
1 - 24.10.18 - 12:31
ЯННП
   Cool_Profi
 
2 - 24.10.18 - 12:31
(1) Для тебя это нормально.
   new_hope
 
3 - 24.10.18 - 12:31
(1) Это матюки?
   PR
 
4 - 24.10.18 - 12:32
Держи нас в курсе, ага
   aleks_default
 
5 - 24.10.18 - 12:32
л_Данные - откуда беруться? Не ошибся?
   PR
 
6 - 24.10.18 - 12:33
(3) Это Яндекс На Неделе Подорожает
   Cyberhawk
 
7 - 24.10.18 - 12:33
(3) Смотря насколько ты испорчен
   new_hope
 
8 - 24.10.18 - 12:35
(7) Дело не в испорченности - пытаюсь понять - что это - "ЯННП" - новый оператор или функция :)
   Cool_Profi
 
9 - 24.10.18 - 12:38
(5) Нет не ошибся, это из предыдущего такого же когда

Смысл простой. Есть конфа. В ней есть правила обмена. Нам нужно внести в эти правила свои изменения. Те правила менять мы не имеем права. Поэтому вносим изменения программног
   Cyberhawk
 
10 - 24.10.18 - 12:39
(8) Это аббревиатура
 
 Рекламное место пустует
   Cool_Profi
 
11 - 24.10.18 - 12:40
(8) Это от слова "я ничего не понял"
   aleks_default
 
12 - 24.10.18 - 12:46
л_ПравилоГрп = л_ПКО.Добавить(XDTOНовый());
   Cool_Profi
 
13 - 24.10.18 - 12:52
(12) "А нет, штанга", Озеров.
Параметров недостаточно.
Если первым параметром пишу "Правило" - Неизвестное свойство:
Свойство 'Правило' не обнаружено
   aleks_default
 
14 - 24.10.18 - 12:55
(13)Значить надо обновить платформу моему телепату. А тебе раскрыть значение:
Имеем в результате запись
<Группа>
//тут элементы правила


</Группа>

А надо бы группа - правило
   Cool_Profi
 
15 - 24.10.18 - 12:57
(14) Что конкретно раскрыть?
Хочу в XML иметь структуру
Группа
  правило
    реквизиты правила
  /правило
/Группа
А имею - 
Группа
  реквизиты правила
/Группа.
   Cool_Profi
 
16 - 24.10.18 - 13:29
Спецы все бу^W^W обедают?
   Cool_Profi
 
17 - 24.10.18 - 14:14
Приятного...
   aleks_default
 
18 - 24.10.18 - 14:18
В моей конфе нет метода XDTOНовый()
   Cool_Profi
 
19 - 24.10.18 - 14:23
(18) Угощайся


Функция XDTOНовый(Знач п_URI=Неопределено,Знач п_ИмяТипа=Неопределено) Экспорт
    Если п_URI=Неопределено Тогда
        п_URI = "http://www.w3.org/2001/XMLSchema";;
    КонецЕсли;
    Если п_ИмяТипа=Неопределено Тогда
        п_ИмяТипа = "anyType";
    КонецЕсли;
    л_Тип = ФабрикаXDTO.Тип(п_URI,п_ИмяТипа);
    Возврат ФабрикаXDTO.Создать(л_Тип);
КонецФункции
   Cool_Profi
 
20 - 24.10.18 - 17:09
Мыслей больше нет?
   Cool_Profi
 
21 - 25.10.18 - 10:19
Так, с частью разобрался, теперь другой вопрос...

Есть СписокXDTO с кучей вложенных объектов и списков...
У объекта (на каком-то уровне вложенности) есть свойство "Код"
Как, не перебирая в цикле, добраться до объекта с нужным мне кодом?
   Cool_Profi
 
22 - 25.10.18 - 14:21
Вопрос на ветер, как я понимаю, но...

Создаю ОбъектXDTO
об = ФабрикаXDTO.Создать("http://www.w3.org/2001/XMLSchema";, "anyType");

А как к нему добавить реквизиты? Схемы нет, всё читается из файла XML автоматом через фабрику.
А хочется в определённое место (я его уже нашёл) добавить ещё подветочку...
   aleks_default
 
23 - 25.10.18 - 15:24
об.ДобавитьДобавить(<Форма>, <URIПространстваИмен>, <ЛокальноеИмя>, <ЭлементДанных>) не?
   Cool_Profi
 
24 - 25.10.18 - 15:36
(23) Последний параметр не прокатывает
   Cool_Profi
 
25 - 25.10.18 - 15:51
Ага...

об1 = ФабрикаXDTO.Создать("http://www.w3.org/2001/XMLSchema";, "anyType");
св = об.Добавить(ФормаXML.Элемент, "http://www.w3.org/2001/XMLSchema";, "Наименование", об1);

Вот так наполовину прокатило... А теперь бы ещё туда значения
Типа <Наименование>ляляля</Наименование>
и атрибуты
типа 
<Код ТипКода="ВПределахРодителя>12</Код>

впихнуть...

Документация что-то молчит...
   aleks_default
 
26 - 25.10.18 - 15:57
Ну тем же Добавить() тока форма атрибут по-моему


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует