Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

В типовой, в начале модуля объекта:Если ОбменДанными.Загрузка Тогда Возврат; КонецЕсли;

В типовой, в начале модуля объекта:Если ОбменДанными.Загрузка Тогда 	Возврат; 	КонецЕсли;
Я
   SkillUp
 
23.10.18 - 09:21
В типовой, в начале модуля объекта:
Если ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;

Зачем? Для чего?
 
 
   aleks_default
 
1 - 23.10.18 - 09:22
Чтобы все последующие процедуры и функциине выполнялись в процессе обмена
   aleks_default
 
2 - 23.10.18 - 09:22
НЕ выполнялись
   Cyberhawk
 
3 - 23.10.18 - 09:26
Правильнее было бы, чтоб весь модуль был с самого начала в блоке "Если НЕ ОбменДанными.Загрузка Тогда ... КонецЕсли;", чтобы разработчик мог уже после этого блока вставлять код, который должен выполняться независимо от режима загрузки
   Cyberhawk
 
4 - 23.10.18 - 09:27
С другой стороны, ничего не мешает добавлять такой блок и перед блоком из нулевого поста, конечно
   unregistered
 
5 - 23.10.18 - 09:31
(0) В начале модуля или в начале какой-то конкретной процедуры или функции?
   catena
 
6 - 23.10.18 - 09:34
Неужели написать на форум быстрее, чем прочитать в СП?

ПараметрыОбменаДанными (DataExchangeParameters)
Загрузка (Load)
Использование:

Чтение и запись.
Описание:

Тип: Булево.
Если значение данного свойства Истина, то при выполнении записи или удаления данных будет производиться минимум проверок, так как при этом делается предположение, что производится запись данных, полученных через механизмы обмена данными, и эти данные корректны.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
   Cyberhawk
 
7 - 23.10.18 - 09:36
(6) Далеко не все умеют извлекать информацию, и еще более далеко не все умеют это делать грамотно.
Для обывателя, обделенного этой способностю, куда проще в любой непонятной ситуации побежать на форум.
   bolder
 
8 - 23.10.18 - 09:37
(0) Ну очевидно же- исключить ненужные операции при загрузке(там есть другие алгоритмы заполнения).Ваш кэп.
   Cyberhawk
 
9 - 23.10.18 - 09:37
(6) Более того, твой подход "разжевал и положил на блюдечко" никак не повышает способность, указанную выше, так что твой первый вопрос с эмоциональным окрасом ("неужели ...?") выглядит как нытье ради нытья.
   ЦиркУехал
 
10 - 23.10.18 - 09:41
(6) Были времена, когда ДенисЧ продавал СП тут. Видать разбогател и уехал наслаждаться жизнью.
 
 Рекламное место пустует
   catena
 
11 - 23.10.18 - 09:44
(9)Ну что поделать, не осталось на форуме менеджеров, которые банчили СП. Остается только ныть :)
   unregistered
 
12 - 23.10.18 - 10:04
Первый раз такое вижу, чтобы это размещали в начале модуля.
Обычно в начале конкретной процедуры или функции.

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует