Вход | Регистрация



Получение периода в обработке расшифровки

Получение периода в обработке расшифровки
Я
   TolstiyBeremenniy
 
22.10.18 - 08:00
В процедуре Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)

выполняю запрос, как получить в этой процедуре значения
параметров &НачалоПериода. &КонецПериода ?
 
 
   TolstiyBeremenniy
 
1 - 22.10.18 - 08:17
Создал у отчета реквизиты НачалоПериода, КонецПериода,
как в них передать значения выбранные в отборе СКД????
   TolstiyBeremenniy
 
2 - 22.10.18 - 08:19
Не пойму как получить значения отбора выбранного в СКД ((
   TolstiyBeremenniy
 
3 - 22.10.18 - 08:25
СхемаКомпоновкиДанных.Параметры.НачалоПериода

можно вот так получать доступ к параметрам в процедуре
при компоновке результата, но там пусто.

Подскажите пожалуйста, как получить НачалоПериода и КонецПериода, установленные в отборе СКД ?
   TolstiyBeremenniy
 
4 - 22.10.18 - 08:31
Никто не знает?
   palsergeich
 
5 - 22.10.18 - 08:39
Сам по себе табличный документ ничего не знает об отборах.
Нужно обращаться к компанией настроек
   palsergeich
 
6 - 22.10.18 - 08:40
К компановщику настроек
   TolstiyBeremenniy
 
7 - 22.10.18 - 08:43
(6) Подскажите пожалуйста, как правильно обратиться?
Я все перебрал никак не смог выявить, как это можно получить!
   TolstiyBeremenniy
 
8 - 22.10.18 - 08:48
(6) Спасибо! Вот так получилось, - 

КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.ДатаНачала

КомпоновщикНастроек.ПользовательскиеНастройки.Элементы[0].Значение.ДатаОкончания
   palsergeich
 
9 - 22.10.18 - 09:00
(8) вполне себе вариант, но лучше привязываться не к порядку элемента, а к его названию, ибо порядок может в процессе разработки измениться.
Но это так, на будущее.
   TolstiyBeremenniy
 
10 - 22.10.18 - 10:13
(9) А как мне получить значение другого поля, строки
на которой я делаю двойной щелчёк?

Вот так я получаю, значение поля на котором произвожу
двойной щелчёк.
ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля()[0].Поле = "Документ"
 
 Рекламное место пустует
   TolstiyBeremenniy
 
11 - 22.10.18 - 10:17
как то же это можно сделать?!!!!
   TolstiyBeremenniy
 
12 - 22.10.18 - 10:20
Мне нужно это что бы использовать значение другого
поля в запросе. Для фильтрации выборки.

Что то не вижу ничего подобного в свойствах (((
   TolstiyBeremenniy
 
13 - 22.10.18 - 10:27
Up!
   TolstiyBeremenniy
 
14 - 22.10.18 - 10:31
Как же это сделать?
   TolstiyBeremenniy
 
15 - 22.10.18 - 10:39
Неужели никто не в курсе??????
   aleks_default
 
16 - 22.10.18 - 10:40
В отладке посмотри
   palsergeich
 
17 - 22.10.18 - 10:40
Обходишь коллекцию элементов циклом, а не обращаешься к элементу по позиции в коллекции
   TolstiyBeremenniy
 
18 - 22.10.18 - 10:52
(16) Так я там и смотрю.
Нигде не могу подобраться к этим значениям,
строки на поле которой делается щелчек.
   TolstiyBeremenniy
 
19 - 22.10.18 - 10:55
(17) У меня не получилось, -
        Для каждого ТекЭл Из ДанныеРасшифровки.Элементы[Расшифровка].ПолучитьПоля() Цикл
        КонецЦикла;
   TolstiyBeremenniy
 
20 - 22.10.18 - 10:56
(17) Подскажите пожалуйста, что именно нужно обходить в цикле?
   TolstiyBeremenniy
 
21 - 22.10.18 - 11:00
(17)
Сам не могу понять.
Подскажите пожалуйста.
   TolstiyBeremenniy
 
22 - 22.10.18 - 11:06
Для каждого ТекЭл Из ДанныеРасшифровки.Элементы Цикл

        КонецЦикла;

https://ibb.co/gzFZY0

А как получать значение полей????

Подскажите пожалуйста, как правильно?
   TolstiyBeremenniy
 
23 - 22.10.18 - 11:07
   Franchiser
 
24 - 22.10.18 - 11:11
Обычно передача делается через дополнительныесвойства
   TolstiyBeremenniy
 
25 - 22.10.18 - 11:12
(24) Подскажите пожалуйста как?!
   TolstiyBeremenniy
 
26 - 22.10.18 - 11:15
Ну вот элементы расшифровки (22), я их перебираю, как мне получить значения другого поля, строки на которой делается двойной щелчёк ?
   TolstiyBeremenniy
 
27 - 22.10.18 - 11:19
Вот есть такая функция

ТиповыеОтчеты.ПолучитьМассивПолейРасшифровки( Расшифровка, ДанныеРасшифровки      )

Но она возвращает массив, с полем и значением по которому производится щелчёк.

А как получить другие значения этой строки???????
   TolstiyBeremenniy
 
28 - 22.10.18 - 11:22
неужели никто не подскажет?????
   TolstiyBeremenniy
 
29 - 22.10.18 - 11:25
Очень нужно, подскажите кто знает. Не могу продвинуться из за этого!
   TolstiyBeremenniy
 
30 - 22.10.18 - 11:32
(17) Можно получить значение поля строки на которой
делается щелчёк в этой процедуре Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)?
   TolstiyBeremenniy
 
31 - 22.10.18 - 11:45
Подскажите пожалуйста!!!!!!
   Вафель
 
32 - 22.10.18 - 11:50
Функция ПолучитьЗначениеГруппировки(ДанныеРасшифровки, Расшифровка, Поле) Экспорт
    
    ДанныеРасшифровкиОбъект = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
    
    ЭлементРасшифровки = ДанныеРасшифровкиОбъект.Элементы[Расшифровка];
    
    Для каждого Родитель из ЭлементРасшифровки.ПолучитьРодителей() Цикл
        
        Для каждого ПолеРосшифровки из Родитель.ПолучитьПоля() Цикл
            
            Если ПолеРосшифровки.Поле = Поле Тогда
                Возврат ПолеРосшифровки.Значение;
            КонецЕсли;    
        
        КонецЦикла;    
        
    КонецЦикла;    
    
    Возврат Неопределено;
    
КонецФункции    

Функция ПолучитьИмяПоля(ДанныеРасшифровки, Расшифровка) Экспорт
    
    ДанныеРасшифровкиОбъект = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
    Поле = ДанныеРасшифровкиОбъект.Элементы[Расшифровка].ПолучитьПоля()[0].Поле;
    
    Возврат Поле;
    
КонецФункции    

   TolstiyBeremenniy
 
33 - 22.10.18 - 12:01
(32) И можно получить данные любого поля?
А то я что не делаю, могу получить только название
поля по которому делаю щелчёк и его значение.
 
 
   TolstiyBeremenniy
 
34 - 22.10.18 - 12:02
(32) Подскажите как это работает? А то не совсем понятно.
   TolstiyBeremenniy
 
35 - 22.10.18 - 12:12
(32) У меня ругается на вот эту строку, -

ДанныеРасшифровкиОбъект = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);


{ВнешнийОтчет.НЗИВ_ОтчетПоЗакупочнойДеятельности.Форма.ФормаОтчета.Форма(14)}: Ошибка при вызове метода контекста (ПолучитьИзВременногоХранилища)
    ДанныеРасшифровкиОбъект = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
по причине:
Ошибка получения значения из временного хранилища
по причине:
Неправильный путь к файлу 'ДанныеРасшифровкиКомпоновкиДанных'
   TolstiyBeremenniy
 
36 - 22.10.18 - 12:22
Не получается, подскажите пожалуйста, как это сделать
на обычных формах?
   TolstiyBeremenniy
 
37 - 22.10.18 - 12:32
Почему у меня ничего не получается??????
Как получить данные соседнего поля?
   TolstiyBeremenniy
 
38 - 22.10.18 - 12:36
(32) Это получение данных одного и того же поля.
Его наименование и значение. а как получить данные
других полей, строки на которой делается даблклик?
   Borteg
 
39 - 22.10.18 - 12:42
(38) Ты клацаешь на "поле", по нему происходит расшифровка. Данные расшифровки относятся к этому полю. Что надо еще получить то?
   Borteg
 
40 - 22.10.18 - 12:44
(38) если используешь макеты в скд на вкладке макеты внизу параметры макета заполни расшифровку и сможешь получить те поля которые там указаны.
   TolstiyBeremenniy
 
41 - 23.10.18 - 03:27
(40) Нет макеты не использую, использую схему СКД.

В процедуре Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)


нужно получить значения полей строки, на поле которой произведен щелчек двойной!
   TolstiyBeremenniy
 
42 - 23.10.18 - 03:44
Вот кажется решение проблемы.


http://catalog.mista.ru/public/383839/


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует