Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

1С Розница

1С Розница
Я
   mirror1982
 
19.10.18 - 14:47
Розница 2.2. Сделал подписку на событие (обработка проведения док-та Поступление товаров и услуг). Добаляю движения по регистру сведений цены номенклатуры. Захожу в движения документа поступление ТиУ, там пусто.

    Док=Источник.Ссылка;
    СписокТоваров=Новый СписокЗначений;
    Для Каждого Строка Из Док.Товары Цикл
        Если СписокТоваров.НайтиПоЗначению(Строка.Номенклатура)<>Неопределено Тогда Продолжить; КонецЕсли;
        СписокТоваров.Добавить(Строка.Номенклатура);
        Движение=Источник.Движения.ЦеныНоменклатуры.Добавить();
         Движение.Период=Док.Дата;
         Движение.Номенклатура=Строка.Номенклатура;
         Движение.ВидЦены=Док.Магазин.ПравилоЦенообразования.ВидЦен;
         Движение.Цена=Строка.РозничнаяЦена;
    КонецЦикла;
    Источник.Движения.Записать();

В чем дело?
 
 
   Повелитель
 
1 - 22.10.18 - 07:01
(0) Зачем нужна эта строка:

Если СписокТоваров.НайтиПоЗначению(Строка.Номенклатура)<>Неопределено Тогда Продолжить; КонецЕсли;
   razlagator
 
2 - 22.10.18 - 07:10
(1) зачем вообще переменная СписокТоваров?
   Случайный прохожий
 
3 - 22.10.18 - 07:21
И вроде человек со стажем задает такой вопрос. Что-то тут явно не чисто :)
   RomaH
 
4 - 22.10.18 - 07:41
Источник.Движения.ЦеныНоменклатуры.Записывать = Истина;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует