Вход | Регистрация


SQL: сторонний сервер SQL Ошибка безопасности SSL.

SQL: сторонний сервер SQL Ошибка безопасности SSL.
Я
   bvb
 
19.10.18 - 13:11
Работаю на терминальном сервере .
БАЗА на сервере 1С предприятия крутится на другом
Обращаюсь к третьему серверу SQL  (не 1С) для прямого SQL запроса 
Все работаало много лет 
Счас херакс :
Произошла исключительная ситуация (Microsoft OLE DB Provider for SQL Server): [DBNETLIB][ConnectionOpen (SECCreateCredentials()).]Ошибка безопасности SSL.

Коннекчусь вот так :


 eXsocet = Новый   COMОбъект ("ADODB.Connection");
     eXrowset = Новый   COMОбъект("ADODB.Recordset");
     
     
     eXsocet.Open(ConnectionString(Server,NameDatabase,UserID,Password));
     eXrowset.ActiveConnection = eXsocet; 
     
     eXrowset.Open(СокрЛП(SqlQuery));


Функция ConnectionString(Server,NameDatabase,UserID = 0,Password = 0)  Экспорт
     Перем ConnectionString;
     
     ConnectionString ="Provider=SQLOLEDB.1;Persist Security Info=False;";
     ConnectionString = ConnectionString + "Initial Catalog="+СокрЛП(NameDatabase)+";Data Source="+СокрЛП(Server)+";";
     Если ПустаяСтрока(UserID) <> 1 Тогда
         ConnectionString = ConnectionString + "User ID="+СокрЛП(UserID)+";";
     Иначе
         ConnectionString = ConnectionString + "Integrated Security=SSPI;";
     КонецЕсли;
     Если ПустаяСтрока(Password) <> 1 Тогда
         ConnectionString = ConnectionString + "Password="+СокрЛП(Password)+";";
     КонецЕсли;
     
     Возврат ConnectionString;
 КонецФункции//ConnectionString
 
 
   Фрэнки
 
1 - 19.10.18 - 13:13
а что спросить-то хотел?
   shuhard
 
2 - 19.10.18 - 13:17
(0) ты ошибку в eXsocet.Open(ConnectionString(Server,NameDatabase,UserID,Password));обработац полностью
будет код ошибки - найдёшь в MSDN
   bvb
 
3 - 19.10.18 - 13:22
(2) подскажи как обработать
Я даже не понимаю на каком из серверов проблема 

На сервере где 1С с OLE DB Provider или на сервере к которому конекчусь

Где смотреть эвент вьюер
   shuhard
 
4 - 19.10.18 - 13:26
(3) [подскажи как обработать]
как обычно, через 
Попытка
// Операторы попытки

Исключение
// Операторы 

исключения
[ВызватьИсключение;]
// Операторы исключения

КонецПопытки;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует