Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Открыть несколько новых документов (УФ)

Открыть несколько новых документов (УФ)
Я
   Bodrug
 
18.10.18 - 11:27
Всем доброго времени суток!
Программно создаю несколько документов "Заказ покупателя" (не записывая) и программно открываю их. Но, в итоге открывается только последний.Код прилагается:

&НаКлиенте
Процедура СоздатьЗаказы(Команда)
    Для Каждого Стр Из ДеревоЗаказов.ПолучитьЭлементы() Цикл
        Если Стр.Узел = "Заказы" Тогда
            Для Каждого Стр1 Из Стр.ПолучитьЭлементы() Цикл
                Если Строка(Стр1.Узел) = "Order" Тогда
                    Для Каждого Стр2 Из Стр1.ПолучитьЭлементы() Цикл
                        Если Стр2.Узел = "OrderId" Тогда
                            Форма = ПолучитьФорму("Документ.ЗаказПокупателя.ФормаОбъекта");
                            ДанныеФормы = Форма.Объект; 
                            СоздатьЗаказыНаСервере(ДанныеФормы, Стр2.Значение);
                            КопироватьДанныеФормы(ДанныеФормы, Форма.Объект);
                            Форма.Открыть();
                        КонецЕсли;
                    КонецЦикла;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;    
    КонецЦикла;
КонецПроцедуры
 
 
   Lexey_
 
1 - 18.10.18 - 11:28
(0) ПолучитьФорму(<ИмяФормы>, <Параметры>, <Владелец>, <Уникальность>, <Окно>, <НавигационнаяСсылка>)

<Уникальность> (необязательный)
Тип: Произвольный.
В данном параметре может быть задан некоторый ключ, значение которого будет использоваться для поиска уже открытых форм. Если будет найдена форма с таким же ключом уникальности, вместо открытия новой формы будет активизирована найденная форма.
   Bodrug
 
2 - 18.10.18 - 11:48
(1) О! Спасибо большое!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует