Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Регламентное задание

Регламентное задание
Я
   Полька
 
18.10.18 - 09:48
8.3.11
ЗУП 3.1.7
Не кидайтесь тапками сильно. Делаю 1 раз. :)
В ЗУП нужно выполнять регламентное задание: запуск внешней обработки.
1. В конфигураторе создала рагл.задание. Предопределенное.
2. В общих модулях создала свой модуль ОбщийМодульРегЗадания. Наставила все "галки" :) Клиент, Сервере, Внешнее Соединение, Вызов сервера.
3. Написала в модуле

&НаКлиенте
Процедура ВыгрузкаВЭДО()   Экспорт
    //Помещаем обработку во временном хранилище

    АдресХранилища = "";
    Результат = ПоместитьФайл(АдресХранилища, "D:\МояОбработка.epf", , Ложь);           
    ИмяОбработки = ПодключитьВнешнююОбработку(АдресХранилища);
    
    // Откроем форму подключенной внешней обработки

    ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма");

КонецПроцедуры

&НаСервере
Функция ПодключитьВнешнююОбработку(АдресХранилища)

    Возврат ВнешниеОбработки.Подключить(АдресХранилища);

КонецФункции     

при сохранении ругается
{ОбщийМодуль._ОбщийМодульРегЗадания.Модуль(18,20)}: Процедура или функция с указанным именем не определена (ПодключитьВнешнююОбработку)
 
 
   Lexey_
 
1 - 18.10.18 - 09:52
(0) директивы компиляции выкинь
   Полька
 
2 - 18.10.18 - 09:55
(1) выкинула
{ОбщийМодуль._ОбщийМодульРегЗадания.Модуль(17,17)}: Процедура или функция с указанным именем не определена (ПоместитьФайл)
    Результат = <<?>>ПоместитьФайл(АдресХранилища, "D:\МОЕ\КД\1c\Conversion\2_1_8_2\v8exchan83.epf", , Ложь);            (Проверка: Сервер)
   Lexey_
 
3 - 18.10.18 - 09:57
(2) это клиентский метод:

Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, мобильное приложение(клиент).
   aleks_default
 
4 - 18.10.18 - 09:59
А зачем свое делать? В ЗУПе же есть рег. задание "Запуск дополнительных обработок"?
   Полька
 
5 - 18.10.18 - 09:59
(3) вернуть &НаКлиенте ?
   Полька
 
6 - 18.10.18 - 10:00
(4) хочу все знать (с) :)))) ну надо же самой понять :)
   Пробел
 
7 - 18.10.18 - 10:01
(2) У Вас внешняя обработка скорей всего лежит в хранилище значения в справочнике с названием вроде "ДополнительныеОбработки". Надо получать оттуда.
   aleks_default
 
8 - 18.10.18 - 10:02
(6)Нужен свой велосипед с квадратными колесами? Понимаю...
   Полька
 
9 - 18.10.18 - 10:02
(7) она лежит пока просто на диске.
   Lexey_
 
10 - 18.10.18 - 10:03
(5) нет, разнести клиентские и серверные процедуры по соответствующим общим модулям
 
 Рекламное место пустует
   Aleksey
 
11 - 18.10.18 - 10:03
Зачем так сложно?
   Aleksey
 
12 - 18.10.18 - 10:04
Сделай через дополнительные обработки. Там есть возможность настроить расписание.
   ZDenis
 
13 - 18.10.18 - 10:05
Регламентные операции выполняются на стороне сервера
   Полька
 
14 - 18.10.18 - 10:08
пошла пробовать через дополнительные
   Aleksey
 
15 - 18.10.18 - 10:32
   Полька
 
16 - 18.10.18 - 12:35
Когда эта обработка была "ручной"- она предполагала заполнение 2х реквизитов и нажатие 2х кнопок.
Сейчас мне ее нужно встроить в конфигурацию, автоматически заполнить реквизиты и описать нажатие этих кнопок?
   aleks_default
 
17 - 18.10.18 - 12:36
(16) да, и сделать это в модуле объекта
   Полька
 
18 - 18.10.18 - 15:30
(17) Поскольку тут сразу все для меня новое: и ЗУП, и рег.задания, и УФ то разгребаюсь потихоньку.
Правильно ли понимаю:
в ОбщемМодуле я должна вызвать встроенную обработку, т.е. какую-то процедуру из модуля объекта обработки

&НаСервере
Процедура ВыгрузкаВЭДО()  Экспорт
    Обработки.МояОбработка.ПроцедураЗапускаМоейОбработкиВРЗ();

КонецПроцедуры
   Cyberhawk
 
19 - 18.10.18 - 15:31
Конфу править это корпоративный стиль там у вас такой?
   Полька
 
20 - 18.10.18 - 16:01
&НаСервере
Процедура ВыгрузкаВЭДО()  Экспорт
    Обработки.МояОбработка.Создать().ПроцедураЗапускаМоейОбработкиВРЗ();

КонецПроцедуры

Эх, если бы из модуля объекта вызвать процедуру модуля формы, как все здорово было бы :)))))
   aleks_default
 
21 - 18.10.18 - 16:23
Там, в общих модулях, все итак уже прописано. И получение из справочника доп. обработок двоичных данных и создание объекта обработки. Тебе нужно просто в модуле обработки нарисовать процедуру с нужным названием и параметрами, которую и будет запускать общий модуль.
Я уже не помню как она там называется, возьми пример из какой-нибудь подключенной доп. обработки.
   aleks_default
 
22 - 18.10.18 - 16:47
вон же в (15) все расписано
   aleks_default
 
23 - 18.10.18 - 16:51
Процедура ВыполнитьКоманду


Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует