Вход | Регистрация



Передача с клиента на сервер

Передача с клиента на сервер
Я
   iznvi
 
17.10.18 - 17:41
Задача состоит так.
Передать функцией которая находится на клиенте значения на процедуре которая находится на сервере и потом отправить все это обратно на клиент.

Хочу сделать это с массивом

&НаКлиенте
Функция ВывестиМассив(М)
    
    М = Новый Массив; 
    М.Добавить("ПередаюМассив"); 
    Возврат М;
    
    
КонецФункции


&НаСервере
Процедура МассивНаСервере(М)
    
    Сообщить(М);  
    
КонецПроцедуры

&НаКлиенте
Процедура Массив(Команда, М)
    МассивНаСервере(М);
КонецПроцедуры


Но значения не передаются
Как это сделать правильно ?
 
 
   aleks_default
 
1 - 17.10.18 - 17:45
Правильно найти пример в книжке, а не задавать глупые вопросы на форуме.
   iznvi
 
2 - 17.10.18 - 17:46
(1) Я облазил уже весь инет.Есть примеры только с Сервера на Клиент,а наоборот нет
   Cool_Profi
 
3 - 17.10.18 - 17:47
А что у тебя в сообщить() выводится?
   iznvi
 
4 - 17.10.18 - 17:49
(3) Пустая строка
   iznvi
 
5 - 17.10.18 - 17:50
(2) Тоесть не передается значение которое я добавляю на сервере
   aleks_default
 
6 - 17.10.18 - 17:50
   iznvi
 
7 - 17.10.18 - 18:01
(3) Получается что не передаются значения
Как их правильнее передать ?
   hhhh
 
8 - 17.10.18 - 18:11
(7) а где тут вызывается функция эта?

Функция ВывестиМассив(М)

ведь нигде?
   iznvi
 
9 - 17.10.18 - 18:12
(8) Если вызываю функцию пишет,что такой функции нет
   iznvi
 
10 - 17.10.18 - 18:13
(8) Эта функция на клиенте
А передать ее на сервер нельзя
 
 Рекламное место пустует
   Fram
 
11 - 17.10.18 - 18:14
   iznvi
 
12 - 17.10.18 - 18:16
(11) Бл,лучше бы подсказали
Только учусь же.
   Fram
 
13 - 17.10.18 - 18:17
(12) это не шутка! это в принципе покажет твою проф пригодность. если у тебя с базовой логикой беда (а судя по вопросам так оно и есть), то может профессия программиста не самый правильный выбор для тебя?
   hhhh
 
14 - 17.10.18 - 18:27
(10) уже ты задавал этот вопрос. передавай на сервер не функцию, а сам массив.
   iznvi
 
15 - 17.10.18 - 18:29
(14) Как это в коде оформить ?
   Вафель
 
16 - 17.10.18 - 18:34
можно сделать
&НаКлиентеНаСервереБезКонтекста

   iznvi
 
17 - 17.10.18 - 18:36
(13) Держи,родной 


равильные ответы: 20 / 30 (66.7%)

Описание:
У вас хорошо развито логическое мышление. Однако вы можете делать ошибки в нестандартных или запутанных случаях. Получив какой-нибудь вывод в результате рассуждения, не торопитесь принимать его за истину. Возьмите за правило перепроверять свои выводы, искать в них ошибки и просто слабые места. Не удивляйтесь, не возмущайтесь, если вас поправляют: возможно, за дело.
   iznvi
 
18 - 17.10.18 - 18:37
(13) Скрин нужен ?
   Exxter
 
19 - 17.10.18 - 18:38
Это как раз нестандартный и запутанный случай.
передать на сервер.....
   Greeen
 
20 - 17.10.18 - 18:40
&НаКлиенте
Функция ВывестиМассив()
    
    М = Новый Массив; 
    М.Добавить("ПередаюМассив"); 
    Возврат М;
    
    
КонецФункции


&НаСервере
Процедура МассивНаСервере(М)
    
    Сообщить(М);  
    
КонецПроцедуры

&НаКлиенте
Процедура Массив(Команда)
    М = ВывестиМассив();
    МассивНаСервере(М);
КонецПроцедуры
   iznvi
 
21 - 17.10.18 - 18:43
(20) Спасибо большое,работает)
Я понял в чем косяк был
   palsergeich
 
22 - 17.10.18 - 19:36
(21) Ждем ваши творения с нетерпением. Старайся и пиши больше, я хочу машинку побольше.
   palsergeich
 
23 - 17.10.18 - 19:42
(17) 20/30 это же ужос. Даже моя жена, гуманитарий от мозга до костей 27 набрала.
А по теме Вам скинули мануалы, вместо того что бы их изучить и понять, Вы начали давить на жалость. В ИТ это не катит, или Вы изучаете то что Вам дают более опытные коллеги и задаете вопросы по существу, или эта область не для Вас.
Всего то требовалось дойти до главы 3 и там более чем подробно все это расписывается.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует