Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как поместить элемент форм в определенное место

Как поместить элемент форм в определенное место
Я
   1сЮлия
 
16.10.18 - 09:52
Доброе утро!В справочник пытаюсь добавила новый реквизит,до этого там не были программно добавлены элементы на форму,а  мне теперь нужно этот реквизит на форму программно разместить как элемент формы пишу, но он лепит мне его вверху сбоку форму,а мне нужно,чтобы в конец формы  Процедура ПриОткрытии()
    Элемент = ЭтаФорма.ЭлементыФормы.Добавить(Тип("ПолеВвода"), "Заказчик", Истина);
    Элемент.Лево = 80;
    Элемент.Верх = 50;
    Элемент.Ширина = 100;
    Элемент.Высота = 20;    
    Элемент.Данные = "Заказчик";    
    Элемент.ИзменяетДанные = Истина; 
    
КонецПроцедуры
 
 
   palsergeich
 
1 - 16.10.18 - 09:57
(0) Это не HTML, тут генератор форм за вас думает, вы всего лишь даете ему рекомендации, а он уже решает согласиться с Вами или нет.
В конструкторе форм сверстайте форму так как надо.
Потом или кодом вбейте настройки или обработкой ДекомпиляторФорм скопируйте код элемента
   la luna llena
 
2 - 16.10.18 - 09:59
(0) сделайте программно группу, поместите ее куда надо
   1сЮлия
 
3 - 16.10.18 - 11:12
Как правильно в группу переместить 
МассивРеквизитов = Новый Массив;
     Для  ии = 1 по ЭтотОбъект.метаданные() Цикл
        
        МассивРеквизитов.Добавить(ЭтотОбъект.Метаданные.Имя);
    КонецЦикла;      
    ИмяГруппы = "грСтраница";
    Если  ЭтаФорма.ЭлементыФормы.Найти(ИмяГруппы) = Неопределено Тогда
        грСтраница = ЭтаФорма.ЭлементыФормы.Добавить(ИмяГруппы, Тип("ГруппаФормы"),);//обрати внимание на третий параметр, указываем родителя, для страницы будет родитель грСтраницы        

        грСтраница.Вид = ВидГруппыФормы.Страница;
    КонецЕсли;
      ЭтаФорма.ЭлементыФормы.грСтраница.Переместить(МассивРеквизитов);
пишет ошибки
   1сЮлия
 
4 - 16.10.18 - 11:30
МассивРеквизитов = Новый Массив;
    Для Каждого р из ЭтотОбъект.Метаданные().Реквизиты Цикл     
         Сообщить(р);
        МассивРеквизитов.Добавить(р);
    КонецЦикла;      
    ИмяГруппы = "грСтраница";
    Если  ЭтаФорма.ЭлементыФормы.Найти(ИмяГруппы) = Неопределено Тогда
работает до сих пор        грСтраница = ЭтаФорма.ЭлементыФормы.Добавить(ИмяГруппы, Тип("ГруппаФормы"),ЭтаФорма);        
        грСтраница.Вид = ВидГруппыФормы.Страница;
    КонецЕсли;
    ЭтаФорма.ЭлементыФормы.грСтраница.Переместить(МассивРеквизитов);
   1сЮлия
 
5 - 16.10.18 - 11:30
Что не так может быть?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует