Вход | Регистрация


У одного пользователя не работает com-соединение

У одного пользователя не работает com-соединение
Я
   Stim213
 
12.10.18 - 21:51
На сервере работает БП 3.0, выгружает по com-соединению документы в базу УНФ. Все работало.

Обновили платформу на 8.3.12.1529.

У одного(!) бухгалтера перестал работать comconnector. Вызывается он так:
КомСоединение = Новый COMОбъект("V83.COMConnector");

платформа выдает ошибки Класс не найден:

https://c.radikal.ru/c29/1810/b1/2669425694bd.png

https://b.radikal.ru/b03/1810/1e/9aa8caf4a4ef.png

Такая ошибка только у одного пользователя, у всех все нормально.


Очищал кеш, ставил в его сеансе админом компоненту comcntr.dll, запускал точно последнюю платформу. Запускал в его сеансе базу под админом. Убивал все прочие сеансы с базами, ничего не помогает.

Куда еще копать?
 
 
   Stim213
 
1 - 12.10.18 - 21:54
базы все файловые, права есть на папки с базами
   H A D G E H O G s
 
2 - 12.10.18 - 21:54
Ахаха, classic!

У кого-то что-то x64, а у кого-то x32
   Stim213
 
3 - 12.10.18 - 21:55
(2) все работают в одном терминальном сервере
   H A D G E H O G s
 
4 - 12.10.18 - 21:56
(3) Ну ты проверь сначало.
   Stim213
 
5 - 12.10.18 - 21:58
(4) а что проверять? сервер 64р, все юзают C:\Program Files (x86)\1Cv8\8.3.12.1529

у меня com работает, под этим бухом - нет
   МимохожийОднако
 
6 - 12.10.18 - 22:30
зарегистрируй com*.dll для новой платформы под этим пользователем
   Сергиус
 
7 - 13.10.18 - 10:37
(0)Проверь, не прописано ли в настройках базы под данным пользователем определенная платформа 1с(старая версия). И как очищал кэш? Удалением и созданием ссылки на базу?
   echo77
 
8 - 13.10.18 - 11:11
(0) Расскажите, как вы так делаете скриншоты, что 90% картинки - белый фон?
   Stim213
 
9 - 13.10.18 - 11:13
(6) делал же
(7) и удалял файлы кеша и базу удалял и добавлял
(8) вырезал ошибку со скрина экрана
   echo77
 
10 - 13.10.18 - 11:15
Антивирус на сервере есть? Может он что-то блокирует?
 
 Рекламное место пустует
   echo77
 
11 - 13.10.18 - 11:16
Грохнуть профиль пользователя в Windows, создать заново?
   Stim213
 
12 - 13.10.18 - 11:16
(10) у одного пользователя? это как так?
   Stim213
 
13 - 13.10.18 - 11:16
(11) ну это совсем по-колхозному
   Stim213
 
14 - 13.10.18 - 11:16
+ и не факт, что поможет
   echo77
 
15 - 15.10.18 - 12:33
(0) Теперь у меня такая же беда.
Работаю со своего компьютера(не в терминале).

1С:Предприятие 8.3 (8.3.11.3133)
   echo77
 
16 - 15.10.18 - 12:40
http://i79.fastpic.ru/big/2018/1015/b3/eb154f3c46002ef0b7d669e4ee0e90b3.png

Зарегистрировал компоненту, запустив CMD от имени администратора командой regsvr32 comctrl.dll
теперь такая ошибка

http://i77.fastpic.ru/big/2018/1015/62/6fb2c7dd1fbf4f3103fdd8cfd2f13162.png
   echo77
 
17 - 15.10.18 - 12:53
Так. У меня решилось. Я компоненту не от той платформы регистрировал.
Зарегистрировал от нужной - все поехало
   kzot
 
18 - 15.10.18 - 12:56
RegDLLView.exe можно было посмотреть.
   Cyberhawk
 
19 - 15.10.18 - 13:06
С таким подходом к деланью скриншотов проблема из ветки - это твоя мгновенная карма, вестимо

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует