Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Заблокировать форму документа сразу после проведения

Заблокировать форму документа сразу после проведения
Я
   ladalady21110
 
12.10.18 - 10:45
Добрый день.
Подскажите, может кто-то сталкивался с задачей: блокировать(ТолькоПросмотр = Истина) форму документа сраааазу же после успешного проведения, если пользователь её не закрыл, не переоткрыл, а просто нажал Провести и остался на ней.

На данный момент максимум чего удалось добиться - блокировать форму проведенного документа при его открытии:

Процедура ПриЧтенииНаСервере(ТекущийОбъект)
    Если Объект.Проведен = Истина Тогда
        ЭтаФорма.ТолькоПросмотр = Истина;
    КонецЕсли;
КонецПроцедуры
 
 
   shuhard
 
1 - 12.10.18 - 10:46
(0) тебе мало событий после записи ?
   Ненавижу 1С
 
2 - 12.10.18 - 10:50
&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)
    Если Объект.Проведен Тогда
        ЭтаФорма.ТолькоПросмотр = Истина;
    КонецЕсли; 
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует