Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: как Узнать Точное Время по интеренету?

v7: как Узнать Точное Время по интеренету?
Я
   Владимир1С
 
11.10.18 - 14:24
Собственно, сабж.
В торговых точках юзвери портят время на компах. Результатом появляется открытая в будущем смена Фискального регистратора. Для того, чтобы избежать подобного, нужно знать точное время по Интернету. Погуглил, не нашёл. Подскажите, пожалуйста, куда копать?
 
 
   shuhard
 
1 - 11.10.18 - 14:25
(0)[, нужно знать точное время по Интернету. Погуглил, не нашёл]
очевидная брехня
   Владимир1С
 
2 - 11.10.18 - 14:28
(1) искал 10 минут. Нит намёка. Всё только ТекущееВремя() . Это не то
   Базис
 
3 - 11.10.18 - 14:29
Админы они у тебя там, что ли? Дай юзеру админский доступ, потом настрой всё нужное и забери права.


(2) Формулировать запрос надо так, чтобы даже мышка понимала. Тогда и гугл даст ответ.
   Владимир1С
 
4 - 11.10.18 - 14:31
(0) да. Это не я решил. И этим я не управляю . Они в регионах.
   Йохохо
 
5 - 11.10.18 - 14:34
w32tm /stripchart /computer:pool.ntp.org /samples:10 >> EtoYaBuduAnalizirovat.txt
   Cool_Profi
 
6 - 11.10.18 - 14:34
Запретить пользователям менять время на компе.
использовать при запуске net time
   shuhard
 
7 - 11.10.18 - 14:34
   Владимир1С
 
8 - 11.10.18 - 14:45
Спасибо всем!
   vcv
 
9 - 11.10.18 - 16:33
А часовой пояс как получить из винды? Может кто подскажет? Без админских прав естественно.
   Йохохо
 
10 - 11.10.18 - 16:35
w32tm /tz
w32tm /?
 
 Рекламное место пустует
   Cool_Profi
 
11 - 11.10.18 - 16:37
(9) Глобальный контекст.ЧасовойПоясСеанса (Global context.SessionTimeZone)
Глобальный контекст (Global context)
ЧасовойПоясСеанса (SessionTimeZone)
Синтаксис:

ЧасовойПоясСеанса()
Возвращаемое значение:

Тип: Строка.
Список допустимых часовых поясов может быть получен методом ПолучитьДопустимыеЧасовыеПояса.
Кроме того, возможно задание часовых поясов смещением от универсального времени (часовые пояса GMT) в формате:
GMT{+/-}h[h][:mm]
где hh=0:23, mm=0:59.
Описание:

Получает идентификатор часового пояса текущего сеанса.

Доступность:

Сервер, толстый клиент, внешнее соединение.
См. также:

Глобальный контекст, метод УстановитьЧасовойПоясСеанса
Глобальный контекст, метод ТекущаяДатаСеанса

--------------------------------------------------------------------------------

     Методическая информация
   Йохохо
 
12 - 11.10.18 - 16:38
(11) s/Методическая информация/Методическая информация для снеговика
   vcv
 
13 - 11.10.18 - 16:39
(10) Не смогло
Часовой пояс: Текущий:TIME_ZONE_ID_UNKNOWN Сдвиг: -300мин (UTC=LocalTime+Bias)
  [Зимнее время:"RTZ 4 (зима)" Сдвиг:0мин Дата:(не указано)]
  [Летнее время:"RTZ 4 (лето)" Сдвиг:-60мин Дата:(не указано)]
   vcv
 
14 - 11.10.18 - 16:40
(11) Ветка про v7
   Йохохо
 
15 - 11.10.18 - 16:40
(13) смогло же, имя только не смогло
   vcv
 
16 - 11.10.18 - 16:42
(15) ОК. Спасибо
   Злопчинский
 
17 - 11.10.18 - 20:12
Функция ВариантВистаИСтарше()
    
    Локатор = СоздатьОбъект("WbemScripting.SWbemLocator");
    Сервис = Локатор.ConnectServer(".");
    Набор = Сервис.ExecQuery("SELECT * FROM Win32_ComputerSystem");
    
    Запись = Набор.ItemIndex(0);
    
    Сдвиг = Запись.CurrentTimeZone / 60;
    Возврат Сдвиг;
    
КонецФункции    

Функция ВариантСкрипт1()

    Скрипт= СоздатьОбъект("MSScriptControl.ScriptControl");
    Скрипт.Language="vbscript";
    Скрипт.AddCode("
        |function GetGMTOffset()
        |    set Service = GetObject(""winmgmts:\\.\root\cimv2"")
        |    set Items = Service.ExecQuery(""SELECT * FROM Win32_ComputerSystem"")
        |    for each Item In Items 
        |        GetGMTOffset = Item.CurrentTimeZone / 60
        |        exit for
        |    next
        |end function
        |");

    Сдвиг = Скрипт.Run("GetGMTOffset");
    Возврат Сдвиг;
КонецФункции    


Функция ВариантСкрипт2()

    Скрипт= СоздатьОбъект("MSScriptControl.ScriptControl");
    Скрипт.Language="vbscript";
    Скрипт.AddCode("
        |function GetGMTOffset()
        |    set Service = GetObject(""winmgmts:\\.\root\cimv2"")
        |    set colTimeZone = Service.ExecQuery(""Select * from Win32_TimeZone"")
        |    for each objTimeZone In colTimeZone 
        |        GetGMTOffset = objTimeZone.Bias/60
        |        exit for
        |    next
        |end function
        |");

    Сдвиг = Скрипт.Run("GetGMTOffset");
    Возврат Сдвиг;
КонецФункции    


Функция ВариантСкрипт3()

    Скрипт=СоздатьОбъект("MSScriptControl.ScriptControl");
    Скрипт.Language="jscript";
    Сдвиг=Скрипт.Eval("new Date()").getTimezoneOffset(0);
    Возврат Сдвиг/60; 
    
КонецФункции    

Процедура Сформировать()  
    ОчиститьОкноСообщений();

    Сообщить("1. Сдвиг от GMT в часах " + ВариантВистаИСтарше()+" ВариантВистаИСтарше");
    Сообщить("2. Сдвиг от GMT в часах " + ВариантСкрипт1()+" "+ВариантСкрипт1);
    Сообщить("3. Сдвиг от GMT в часах " + ВариантСкрипт2()+" "+ВариантСкрипт2);
    Сообщить("4. Сдвиг от GMT в часах " + ВариантСкрипт3()+" "+ВариантСкрипт3);
    
КонецПроцедуры
   NorthWind
 
18 - 11.10.18 - 21:41
>> В торговых точках юзвери портят время на компах -- исправлять надо это в первую очередь. Для этого юзерам запрещают менять системное время и настраивают синхронизацию либо с сервером времени на домене, либо, если домена нет, с доступными в инете NTP-серверами. Которые запросто гуглятся.
   NorthWind
 
19 - 11.10.18 - 21:45
можно для вящего покою еще сделать принудительную синхронизацию времени при запуске компа. У меня был один ноутбук, в котором что-то заклинило в южном мосту и он время показывал какое угодно, кроме нужного. Мог, например, на 2100 год скакнуть после включения, тогда винда не грузилась, но чаще убегало менее экстремально. Нашел какую-то утилиту, которая могла хоть раз в минуту время подправлять. Так и жил, пока не сменил его... Если интересно, могу посмотреть, ноутбук до сих пор лежит в шкафу.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует