Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

разблокирование реквизита в ТЧ

разблокирование реквизита в ТЧ
Я
   pups777
 
11.10.18 - 13:59
добрый день .такая задача.весь документ надо заблокировать при открытии но в ТЧ открыть две колонки на редактирование .Скидка процентом и скидка суммой.делаю как в коде :разблокирую с начала ТЧ ТоВАРЫ а потом нужны реквизит но ничего не выходит хотя сообщалки отрабатывают

    если ПользователиИнформационнойБазы.ТекущийПользователь().Имя="Админ" Тогда 
        //цикл по всем элементам формы и блокировка всех реквизитов кроме....трех

        Для каждого Элемент Из ЭтаФорма.ЭлементыФормы цикл 
            Имя_ = Элемент.Имя;
            Если имя_="Товары" Тогда 
                Элемент.Доступность= Истина; 
                //////////////////////////////////////////////////////////////////////////

                сообщить("тест1");
                Для каждого Элемент2 Из ЭтаФорма.ЭлементыФормы.Товары.Колонки цикл 
                    Имя_2 = Элемент2.Имя;
                    Если имя_2="ПроцентСкидкиНаценки" ИЛИ имя_2="СуммаАвтоматическихСкидок" Тогда 
                        Элемент2.Доступность= Истина;
                        сообщить("тест2");
                    Иначе
                        Элемент2.Доступность= Ложь;
                    КонецЕсли; 
                КонецЦикла;    
                /////////////////////////////////////////////////////////////////////////

            Иначе
                Элемент.Доступность= Ложь; 
            КонецЕсли;    
        КонецЦикла;
    КонецЕсли;
 
 
   Cool_Profi
 
1 - 11.10.18 - 14:01
Если ты весь документ через Форма.ТолькоПросмотр блокируешь, остальные движения любыми частями тела не помогут
   Darych
 
2 - 11.10.18 - 14:02
бред какой
   pups777
 
3 - 11.10.18 - 14:02
(1)подскажите как правильно?
   Cool_Profi
 
4 - 11.10.18 - 14:03
(3) Все реквизиты в форме перебирай и блокируй
   Diablo_007
 
5 - 11.10.18 - 14:03
(0) Родительские реквизиты блокируются. То есть сам список, а значит и все элементы в нём, попробуй сделать проверку на подчененные элементы, если пусто, тогда блокируй, иначе нет.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует