Вход | Регистрация



Продажа металлолома, отражение НДС

Продажа металлолома, отражение НДС
Я
   bizon2008
 
11.10.18 - 09:05
Продажа металлолома, отражение НДС
Хай пипл.
Значится так. Конфа УПП 1,3. Продали металлом.
Вроде все сделаю по учебнику. В договоре посвили нужный флажок.
В документе реализация товаров и услуг Без НДС.
Счет фактура с нужным кодом.
А в книгу продаж не попадает.
Где косяк?
 
 
   shuhard
 
1 - 11.10.18 - 09:32
(0)[Вроде все сделаю по учебнику]
не о чем
   bizon2008
 
2 - 11.10.18 - 09:45
(1) Ну как на ИТС написано.
   МимохожийОднако
 
3 - 11.10.18 - 09:47
(0) Косяк в том, что делаешь не всё, что написано по учебнику (ИТС)
   bizon2008
 
4 - 11.10.18 - 09:49
(3) Логично. Там блин для БП у на УПП. Что-то пропустил.
   bizon2008
 
5 - 11.10.18 - 09:50
(3) Логично. Там блин для БП у нас же УПП. Что-то пропустил.
   shuhard
 
6 - 11.10.18 - 10:05
(2) топик ни о чем
   bizon2008
 
7 - 11.10.18 - 10:42
(6) Я тебя с первого раза понял.
   Базис
 
8 - 11.10.18 - 11:14
Начинаем ролевую игру "дебаг".

Собеседника зафиксировал, лампу в лицо направил.

Какой код ожидаешь в книге? Есть ли он в конфигураторе? В форме СчФ? Что изменил в справочниках и документах по сравнению с не-ломом?

Ну хоть релиз назови....
   gantonio
 
9 - 11.10.18 - 11:17
а он там есть это металлом то ? а то ведь они вначале артачились и не вставляли его во все конфигурации.
   Winnie Buh
 
10 - 11.10.18 - 11:38
(9) почему "сначала"? НДС по лому и сейчас в типовой БП вроде как нет, предлагают на БП КОРП переходить
 
 Рекламное место пустует
   Mraque
 
11 - 11.10.18 - 11:47
В формирование книги продаж не должно попадать.
Счет-фактура с кодом 34 напрямую попадет в отчет "Книга продаж 1137".
   bizon2008
 
12 - 12.10.18 - 11:10
(8) 34 код ожидаю. Да хрен с ним с кодом. Записи нет однако.
Есть в конфигурации.
Конфа УПП 1,3
И счет фактура нормальная, и договоре флажок стоит.
Но методики в договоре флажок ставить надо. флажок стоит.
   bizon2008
 
13 - 12.10.18 - 11:20
(11) Нету тама эти кодов.
   shuhard
 
14 - 12.10.18 - 11:41
(12) что-то мешает использовать отладчик ?
   bizon2008
 
15 - 12.10.18 - 12:05
(14) Отладчик ничего не мешает использовать, но тама такая куча кода, я потерялся уже. Плюс НДС последовательность отдельно восстанавливается
   Гипервизор
 
16 - 12.10.18 - 12:09
(13) Еще раз: в документ или в отчет не попадает?
   shuhard
 
17 - 12.10.18 - 12:10
(15) да лан
поиск по реквизиту справочника не даёт тучу кода
   gantonio
 
18 - 12.10.18 - 12:12
там кода всего строчек 8 надо вставить или того меньше.
   shuhard
 
19 - 12.10.18 - 12:12
(0)[В документе реализация товаров и услуг Без НДС. ]
стоп
любая ставка, кроме Без НДС !
механизм нужен именно для сочетания реальной ставки и направления НДС в печатную форму СФ и журналы
   Гипервизор
 
20 - 12.10.18 - 12:18
(0)(19) Откуда там вообще взялось поле со ставкой, если в договоре соответствующая галка?
Программно заполняли чтоли?
   bizon2008
 
21 - 12.10.18 - 12:28
(16) И документ и в отчет не попадает. Нигде нет.
   bizon2008
 
22 - 12.10.18 - 12:29
(20) Поле в документе есть, стандартное.
   bizon2008
 
23 - 12.10.18 - 12:32
Все парни, походу нашел косяк. Они металлолом не как товар продают, а как услугу.
Пошел читать законодательство.
   Быдло замкадное
 
24 - 12.10.18 - 12:35
(23) т.е. в документе реализации ты не замечал что номенклатура не на той закладке даже находится?
   shuhard
 
25 - 12.10.18 - 12:45
(23) поржал, от души
чмокни бухов в щёчку - за нас =)
   Гипервизор
 
26 - 12.10.18 - 12:46
(22) А быть не должно.
   bizon2008
 
27 - 12.10.18 - 13:03
(24) Угуй. Они мне так мозг вынесли. Что да протормозил. (25) А можно я их лопатой?
(26) Ну значится недоработка. НДС в доке есть всегда. Я все варианты перепробовал.
   Гипервизор
 
28 - 12.10.18 - 13:05
(27) Процедура СкрытьНДСПриРеализацияТоваровОблагаемыхНДСУПокупателя()
Поищите в форме документ.
   bizon2008
 
29 - 12.10.18 - 13:33
(28) Есть такая процедура.
Не отрабатвает, потому что Константы.ДатаНачалаОперацийСТоварамиОблагаемымиНДСУПокупателя пустая, а пустая она, потому что ее нет в пользовательском интерфейсе однако. Вот такая недоработка.

Спасибо.
   Гипервизор
 
30 - 12.10.18 - 14:47
(29) Однако же в общем модуле ПроцедурыОбновленияИнформационнойБазы:
Процедура УстановитьДатуНачалаОперацийСТоварамиОблагаемымиНДСУПокупателя() Экспорт
    Константы.ДатаНачалаОперацийСТоварамиОблагаемымиНДСУПокупателя.Установить(Дата("20180101"));
КонецПроцедуры

Так что вопрос - как вы так обновляли конфу, что у вас константа пустая?
   bizon2008
 
31 - 12.10.18 - 14:56
(30) Обновлял не я однако.
   bizon2008
 
32 - 12.10.18 - 15:05
Я ее лапками поставил, но условие все рано не отрабатывает.
Хотя там кода мелочь.
Процедура УстановитьРеализацияТоваровОблагаемыхНДСУПокупателя()
    РеализацияТоваровОблагаемыхНДСУПокупателя = ДоговорКонтрагента.РеализацияТоваровОблагаемыхНДСУПокупателя 
        И ЭтотОбъект.Дата >= Константы.ДатаНачалаОперацийСТоварамиОблагаемымиНДСУПокупателя.Получить();
        
    СкрытьНДСПриРеализацияТоваровОблагаемыхНДСУПокупателя();
    
КонецПроцедуры

Процедура СкрытьНДСПриРеализацияТоваровОблагаемыхНДСУПокупателя()
    
    // В случае реализации лома, скрываются колонки СтавкаНДС, СуммаНДС, Всего

    ОбработкаТабличныхЧастей.УстановитьВидимостьКолонкиТабЧасти(мКолонкиТовары.СтавкаНДС, Не РеализацияТоваровОблагаемыхНДСУПокупателя);
    ОбработкаТабличныхЧастей.УстановитьВидимостьКолонкиТабЧасти(мКолонкиТовары.СуммаНДС, Не РеализацияТоваровОблагаемыхНДСУПокупателя);
    ОбработкаТабличныхЧастей.УстановитьВидимостьКолонкиТабЧасти(мКолонкиТовары.Всего, Не РеализацияТоваровОблагаемыхНДСУПокупателя);
    // ... и надпись ВсегоНДС

    ЭлементыФормы.НадписьВсегоНДС.Видимость = Не РеализацияТоваровОблагаемыхНДСУПокупателя;
    ЭлементыФормы.ВсегоНДС.Видимость = Не РеализацияТоваровОблагаемыхНДСУПокупателя;
    
КонецПроцедуры
   hhhh
 
33 - 12.10.18 - 15:07
(30) тут всё-таки ДатаНачалаОперацийСТоварамиОблагаемымиНДСУПокупателя

а у нас услуги. Это в принципе не должно срабатывать, потому что насчет услуг никаого закона не было.
 
 
   bizon2008
 
34 - 12.10.18 - 15:08
Да понятно уже. Но где блин где - Если Тогда в (32) Как оно вообще работает?
   hhhh
 
35 - 12.10.18 - 15:10
(34) для ТЧ товары работает. Заведи металлолом как товар
   bizon2008
 
36 - 12.10.18 - 15:12
(35) Не работает, колонки не скрываются однако.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует